Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 31st, 2013, 04:08 PM
macfink macfink is offline
 
Join Date: Feb 2011
Posts: 685
Default site map problems

Hi Eric,

I have tried to set my site map in Web tools, but it says this?

We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

freakfish.co.uk/shop/sitemap

This should be the location of the site map?
__________________
ID 30949
Website:
http://www.freakfish.co.uk/
  #2  
Old January 31st, 2013, 05:18 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

I see your sitemap at that address so I think it's getting rendered fine.

However at the bottom of the sitemap source code I see the following code:

Code:
<!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

Minified using disk: basic
Page Caching using disk: enhanced
Database Caching using disk: basic
Object Caching 246/298 objects using disk: basic

Served from: www.freakfish.co.uk @ 2013-01-31 22:16:01 -->
That code might be the issue. You should stop that from appearing on that page because that's probably the code that's causing the problem and it's not even successfully caching the page (from what I can tell).

Eric
  #3  
Old January 31st, 2013, 06:22 PM
macfink macfink is offline
 
Join Date: Feb 2011
Posts: 685
Default

I have looked in the settings and i cant see whats putting that code in there?

Also the frequency is set to never changed? Would you mind having a quick look for me?
__________________
ID 30949
Website:
http://www.freakfish.co.uk/
  #4  
Old January 31st, 2013, 06:24 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

You can change the frequency here: The Factory > Your Store > Store menu > Sitemap Settings.

Eric
  #5  
Old January 31st, 2013, 06:33 PM
macfink macfink is offline
 
Join Date: Feb 2011
Posts: 685
Default

any ideas about getting that code out?
__________________
ID 30949
Website:
http://www.freakfish.co.uk/
  #6  
Old January 31st, 2013, 06:34 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by macfink View Post
any ideas about getting that code out?
Not really... I would look for an option in that plugin that allows you to disable caching on specific pages.
  #7  
Old January 31st, 2013, 07:21 PM
macfink macfink is offline
 
Join Date: Feb 2011
Posts: 685
Default

I have already done this

The same setting apply to rideon.co.uk and theres none of that code in that site map

At present i have no products being indexed. I'm lost
__________________
ID 30949
Website:
http://www.freakfish.co.uk/
  #8  
Old January 31st, 2013, 07:26 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by macfink View Post
The same setting apply to rideon.co.uk and theres none of that code in that site map
I see the same code in your other store's sitemap, too:

Code:
<!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

Minified using disk: basic
Page Caching using disk: enhanced (User is logged in)
Database Caching using disk: basic
Object Caching 240/293 objects using disk: basic

Served from: www.rideonsurfshop.co.uk @ 2013-02-01 00:24:54 -->
And I'm not sure why it says I'm logged in as I was not logged into your site. I double checked by going to /wp-admin/.

Last edited by Eric : January 31st, 2013 at 07:29 PM. Reason: added more info
  #9  
Old January 31st, 2013, 07:35 PM
macfink macfink is offline
 
Join Date: Feb 2011
Posts: 685
Default

thats odd i cant see that. also theres no warnings in wmt

view-source:http://www.rideonsurfshop.co.uk/store/sitemap
__________________
ID 30949
Website:
http://www.freakfish.co.uk/
  #10  
Old January 31st, 2013, 07:37 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by macfink View Post
thats odd i cant see that. also theres no warnings in wmt

view-source:http://www.rideonsurfshop.co.uk/store/sitemap
I get it while in a different browser as well:

Code:
<!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

Minified using disk: basic
Page Caching using disk: enhanced
Database Caching using disk: basic
Object Caching 240/293 objects using disk: basic

Served from: www.rideonsurfshop.co.uk @ 2013-02-01 00:36:10 -->
  #11  
Old January 31st, 2013, 07:47 PM
macfink macfink is offline
 
Join Date: Feb 2011
Posts: 685
Default

I really don't get it

both site maps have that code in, how its being placed in there i have no idea.

ride on is being uploaded fine and freakfish isnt.
__________________
ID 30949
Website:
http://www.freakfish.co.uk/
  #12  
Old January 31st, 2013, 07:51 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

It appears that you can exclude files and directories from being cached under Page Cache > Never cache the following pages:

You should also disable minify on the sitemap page under Minify > Never minify the following pages:

Beyond that, I can't really provide support for the W3 Total Cache plugin. I don't use it and I don't know my way around it. If you have further questions regarding how to disable Caching and disable Minifying on specific pages, you will need to ask the W3TC folks.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rebuilt site ... and having problems correcting URL settings... jenng22 Problems 3 July 10th, 2012 07:10 AM
Can I get the Amazon URL within the site so I can modify URL within the site sandeep821 Questions 2 April 26th, 2012 10:20 AM
Subscriptions - change from 5 site to 10 site redspan Questions 3 August 14th, 2011 12:44 PM
URL problems macfink Problems 2 March 21st, 2011 09:51 AM


All times are GMT -5. The time now is 12:58 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.