Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old August 6th, 2012, 08:04 PM
pr2c3L3b pr2c3L3b is offline
 
Join Date: Jul 2012
Posts: 64
Question Wrong products in feed

Store 38656


Hi,

I have been checking my store categories etc.

I discovered that one of my sunglasses category is returning the wrong products in the feed.

For example, I have Blvgari sunglasses listed in my products in the Blvgari categories under sunglasses top level category. However, when I click on the Sunglasses> Bvlgari catgeory category in the font end of the website, it shows Bvlgari perfumes instead.
If you go to this page and click on the Bvlgari subcategory, you will see what I mean

http://www.makeupminx.net/store/cate...unglasses-a-g/

I do have another Fragrance category with Bvlgari products but that is separate.

Another issue is that under my Fragrance category at the front end of the website, it displays the subcategories out of order. They are in order in the Factory end of the shop.

http://www.makeupminx.net/store/category/fragrance/

Would appreciate your help with this. The categories all seemed in order when we first checked them however, there have been updates so something has gone wrong.

Merchant images across all products are missing too.

I amy have to put the site on to maintenance mode to clean this up.

Thank you,

Shannon
  #2  
Old August 6th, 2012, 10:32 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Here's how to solve this issue: /show...9060#post19060

Eric
  #3  
Old August 7th, 2012, 08:22 PM
pr2c3L3b pr2c3L3b is offline
 
Join Date: Jul 2012
Posts: 64
Default

Quote:
Originally Posted by Eric View Post
Hi

Here's how to solve this issue: /show...9060#post19060

Eric
Hello Eric,

Thank you, I followed the instructions replacing the %cs with %cp in the url settings as suggested.

The correct product title appears for fashion sunglasses products and for the subcategory products but now no images are appearing for the category or subcategies e.g. sunglasses A-B .

http://www.makeupminx.net/store/cate...s-a-g/bvlgari/

Also when I click on more info button for a sunglasses product, it redirects to the website homepage.

I should add that I do not use the single product view.

Also the top level domain fragrances subcategories list still appears out of order at the front end of the website but in order in the factory. http://www.makeupminx.net/store/category/fragrance/

Appreciate help as soon as poss.

Thank you,

Shannon
  #4  
Old August 8th, 2012, 06:53 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Try changing this: store/%cp/%ps-%pi/
To this: store/product/%cp/%ps-%pi/
Here: The Factory > Your Store > Store menu > URL Settings > Product detail page

Eric
  #5  
Old August 8th, 2012, 07:46 AM
pr2c3L3b pr2c3L3b is offline
 
Join Date: Jul 2012
Posts: 64
Default

Hello Eric,

I made the change you suggested and updated.
Not sure what that was supposed to fix?

Now, when I click on the image of a Bvlgari sunglasses product , it takes me to an image of the product with a 'buy' button. If I click on that 'buy' button, it redirects to my website's homepage instead of the merchant's website. Doh!

I need the more info buttons for the products on my site redirect to the merchants website. Are you able to look at the site and work out why this is happening? Do you need the site off maintenance mode?

Thanks
  #6  
Old August 8th, 2012, 07:48 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Yes, you need to turn off maintenance mode before I can help further.

Eric
  #7  
Old August 8th, 2012, 07:56 AM
pr2c3L3b pr2c3L3b is offline
 
Join Date: Jul 2012
Posts: 64
Default

Ok I have just done that and now in process of product update.

Also, I had made the changes re image loading problems by following the instructions in this link you gave me earlier to get images directly from merchant- /showthread.php?t=6858

I am still getting random products mostly from perfume.com at the moment. where the image does still not load; all I see is the blue square with the question mark. Is there a way , I can have a message that says image unavailable when the merchant's image does not download ?
  #8  
Old August 8th, 2012, 07:58 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I changed store/product/buy/%pi/%ps/ to store/product/buy/%pi/ for your "Buy" URL Settings and that seems to have fixed the issue.

Please send a URL to a page where images are not loading. I see all of your images fine.

Eric
  #9  
Old August 8th, 2012, 08:04 AM
pr2c3L3b pr2c3L3b is offline
 
Join Date: Jul 2012
Posts: 64
Default

Thanks. The images randomly fail to load; it's variable. Tonight, it seems to be an issue with perfume.com mainly on the fragrance category and subcats.

http://www.makeupminx.net/store

http://www.makeupminx.net/store/category/fragrance/

Almost sorted I hope.

Did you know why the Fragrance Brands subcategory is out of alphabetical order at the front end of the website? In the factory I have the list in alphabetical order, so cannot understand why it appears different at front end.

Thanks
  #10  
Old August 8th, 2012, 08:14 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

It seems Perfume.com is supplying invalid image URLs in their feed. For example, this is the URL for one of their product images:

http://images/missing/original/noimage.jpg

It doesn't even contain a domain name!

I'm looking into the sub-category sort order.

Eric
  #11  
Old August 8th, 2012, 08:21 AM
pr2c3L3b pr2c3L3b is offline
 
Join Date: Jul 2012
Posts: 64
Default

Ok, I might cancel their program. I have communicated with them thru' the network mail system about their images but have no response as yet.

Thanks for looking at the sub-category order issue.
  #12  
Old August 8th, 2012, 09:29 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by pr2c3L3b View Post
Thanks for looking at the sub-category order issue.
There was an extra space before the "J" in your category name. Removing it fixed the issue.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Products are wrong seoandbeyond Questions 3 November 23rd, 2011 09:30 PM
Wrong products in store cols2910 Problems 4 August 19th, 2011 12:59 PM


All times are GMT -5. The time now is 01:09 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.