Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old March 7th, 2012, 01:26 PM
rossboardman rossboardman is offline
 
Join Date: May 2010
Posts: 21
Default Slow loading pages

Store ID: 35264
Website URL: http://www.shoppingcataloguesuk.com
URL to page in question: Any non cached page

I've got some issues with some very slow loading pages. It is only non-cached shop pages and not other pages within wordpress.

I have:

a) enabled view caching within the factory
b) got hyper cache plugin installed
c) got DB Cache Reloaded Fix plugin installed
d) optimized the tables in the db using DB manager plugin

With nothing in caches the pages can take up to 17 seconds to load the HTML. I'm fairly confident everything is OK when the HTML has come in. The CSS, images etc I have moved locally and can move them to a CDN if need be.

It seems as if the db query is what is taking the time. With over 80k products is this the issue? I do colours and shapes so databases aren't really my thing.

I have thought about warming the cache but I can't seem to generate a site map to start from. If the site had traffic there wouldn't be a problem as the pages would be served from the cache. Problem is that it is a new site and I don't think people will wait for the pages to load.

Any ideas much appreciated.

cheers
Ross
  #2  
Old March 7th, 2012, 01:56 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi Ross,

I still think the problem is related to the issue I mentioned in your other thread:
/show...9567#post29567

You need to change occurrences of %cs with %cp in your URL Settings. You have too many categories with the same name which are causing redirect loops that cause problems.

Eric
  #3  
Old March 8th, 2012, 03:00 AM
rossboardman rossboardman is offline
 
Join Date: May 2010
Posts: 21
Default

Hi Eric

I have changed the settings to %cp as you describe but it still seems to take forever to load the category pages.

If you click on the links under the description of the page:

http://www.shoppingcataloguesuk.com/...tegory/womens/

you will see that it is taking approx 20 seconds before the page appears.

cheers
Ross
  #4  
Old March 8th, 2012, 09:37 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I think those pages are still cached.

The links to the Accessories page should be this:
http://www.shoppingcataloguesuk.com/shop/category/womens/accessories/

Not this:
http://www.shoppingcataloguesuk.com/shop/category/accessories

I imported your store into my test site and the pages load quite fast, especially after the Datafeedr plugin cached them!

Try this:

1. Deactivate the hyper cache plugin
2. Deactivate the DB Cache Reloaded Fix plugin
3. Upgrade your Datafeedr plugin to the latest version here: WordPress Admin Area > Tools > Datafeedr
4. After the Datafeedr plugin is upgraded, click the [Update Products and Settings] button

I think after you take these steps, your site will run faster.

Eric
  #5  
Old March 8th, 2012, 01:49 PM
rossboardman rossboardman is offline
 
Join Date: May 2010
Posts: 21
Default

Hi Eric

Thanks very much for your help with this. Things appear to be loading a lot quicker now. About 7 seconds for an uncached page which is better than the 20 seconds we had before.

How do I send you a beer?
  #6  
Old March 8th, 2012, 02:43 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

One other thing you could try is changing the images which load on category pages from "images" to "thumbnails".

Just go here: The Factory > Your Store > VIEWS > CATEGORY PAGE > Default > Product list module and change occurrences of [product.image to [product.thumbnail

You are loading large images on every page load.

Eric
  #7  
Old March 9th, 2012, 12:25 AM
rossboardman rossboardman is offline
 
Join Date: May 2010
Posts: 21
Default

Thanks for that. I tried it but the images were too small.

One thing I tried at work with MVT was the optimum size of images on a category page. I wanted them to be that big. Shame about the initial download hit.

The pages seem to be loading a lot quicker now which is cool. Thanks again for your help.

cheers
Ross
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
slow store squeezywheezy Problems 1 October 20th, 2011 06:04 PM
store not loading kjricci Problems 1 October 19th, 2011 09:07 AM
slow loading pages squeezywheezy Problems 10 October 14th, 2011 04:57 PM
Logo Loading issue Shoesearch Problems 5 July 13th, 2011 11:11 AM


All times are GMT -5. The time now is 12:56 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.