Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Questions
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old November 19th, 2011, 11:31 AM
digitalcow digitalcow is offline
 
Join Date: Jun 2010
Posts: 494
Default Alt Text

Eric

How would one go about getting alt text on images? I have tried numerous ways but none of them are working. The default image is coming out thusly in the html <img src="/store/image/416602088326671/oroblu-milly-hold-ups/" alt=" Store" title="Oroblu Milly Hold Ups" />&nbsp;</ - while the title is in the title I would also like it in the alt for seo purposes

I have tried to use <img src="URL" alt="[product.name]" /> and <img src="[product.image tag='1']" alt="[product.name]" /> but no joy

Last edited by digitalcow : November 19th, 2011 at 11:32 AM.
  #2  
Old November 19th, 2011, 12:31 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Try this:
HTML Code:
<img src="[product.image tag='0']" alt="<?php echo str_replace('"', '&quot;', $product->name); ?>" title="<?php echo str_replace('"', '&quot;', $product->name); ?>" />
Eric
  #3  
Old November 19th, 2011, 01:25 PM
digitalcow digitalcow is offline
 
Join Date: Jun 2010
Posts: 494
Default

Eric,

Unless I have placed that in the wrong place it is still showing alt=store, see http://brighttights.com/store/produc...-15-stockings/
  #4  
Old November 19th, 2011, 05:44 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Try this:
HTML Code:
<?php $sant_name = str_replace('"', "&quot;", $product->name); ?>
<img src="[product.image tag='0']" alt="<?php echo $sant_name; ?>" title="<?php echo $sant_name; ?>" />
  #5  
Old November 20th, 2011, 05:05 AM
digitalcow digitalcow is offline
 
Join Date: Jun 2010
Posts: 494
Default

Nope, still not working. I have included my product detail page code below

Quote:
<!-- Single Product -->
<div class="sp">
<div class="lc">
<div class="thmb">
<a href="[product.url direct='0']" title="[product.name]" target="_blank">
<?php $sant_name = str_replace('"', "&quot;", $product->name); ?>
<img src="[product.image tag='0']" alt="<?php echo $sant_name; ?>" title="<?php echo $sant_name; ?>" />
</a>
</div>
</div>
<div class="rc">
<h2>
<a href="[product.url direct='0']" title="[product.name]" target="_blank" style="text-decoration: none">
<span style="font-size:14px;"> <span style="color:#464444;">[product.name]</font></a></h2>
</br>
<p class="desc">[product.merchant_logo]</p>
</br>
<p class="desc"><font size="2">[product.description]</font></p>
<div class="prc"><b>[product.currency mode="sign"][product.price]</b></div>
<div class="btns">
<a href="[product.url]" class="dfbutton dfblack dfmedium dfrounded" title="Buy this product" target="_blank">Visit Reatiler</a>
</div>
</div>
<div class="clearingdiv"> </div>
</div>
<script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:like href="[server.url type='fullpage']" show_faces="false" width="450" font="arial"></fb:like>

<!-- /Single Product -->
when I view the html on a live site I am still seeing <img src="/store/image/509402088995644/natural-comfort-non-wired-bra/" alt=" Store" title="Natural comfort non-wired bra" />
  #6  
Old November 20th, 2011, 10:38 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

It's working for me. You must have a plugin rewriting the alt attribute on your images. Or possibly your theme is doing it. I imported your store into my test site and the alt was exactly was it should be.

Eric
  #7  
Old November 20th, 2011, 11:12 AM
digitalcow digitalcow is offline
 
Join Date: Jun 2010
Posts: 494
Default

Working now. I turned all my plugins off and back on and it turned out to be a random error logging plugin causing the problem.

Thanks for your help on this matter and the pagination. I ran the site through an seomoz scan yesterday and it picked up about 9,000 errors/issues. These were mainly duplicate titles (the category titles), no alt text and a few random others which I have fixed.
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing the text in tab youngy Questions 1 July 13th, 2011 09:11 AM
Change Button text bucs0658 Questions 2 May 19th, 2011 11:18 AM
Sub Cat text not centred macfink Questions 6 March 31st, 2011 02:20 PM
Text Removal macfink Questions 1 March 29th, 2011 11:27 AM


All times are GMT -5. The time now is 12:53 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.