Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old February 2nd, 2014, 11:17 AM
matzii matzii is offline
 
Join Date: Sep 2013
Posts: 138
Default update error

my site:
parfymeri.se

i receive several hundreds of mail with different errors like this:

ERROR:
-Too many concurrent updates running (more info: http://www.datafeedr.com/go/err_update_lock_failed)

Technical details:
plugin/plugin:152 view=(product)
app/tracker:61 track: no referrer
ERROR:filemtime(): stat failed for /www/webvol3/cl/gxbv123456789/parfymeri.se/public_html/wp-content/uploads/store/temp/_dfrcache_1001b29dd9f17e96812857bde047b050() line=1832
ERRORskip) mysql_query(): MySQL server has gone away (/www/webvol3/cl/gxbv5dtfle10egh/parfymeri.se/public_html/wp-content/plugins/datafeedr/datafeedr.php:746)()
ERRORskip) mysql_query(): Error reading result set's header (/www/webvol3/cl/gxbv5dtfle10egh/parfymeri.se/public_html/wp-content/plugins/datafeedr/datafeedr.php:746)()
ERROR:err_mysql(2006(MySQL server has gone away):SELECT * FROM wp_parfymeri_se_dfr_shop_products WHERE id='1810802088058803') ERROR:err_mysql(2006(MySQL server has gone away):SELECT id FROM wp_parfymeri_se_dfr_shop_compsets WHERE product_id='1810802088058) ERROR:err_mysql(2006(MySQL server has gone away):SELECT sval FROM wp_parfymeri_se_dfr_xopt WHERE skey='update_lock') ERROR:err_mysql(2006(MySQL server has gone away):REPLACE INTO wp_parfymeri_se_dfr_xopt(skey,sval) VALUES('update_lock', '47754-6c) ERROR:err_mysql(2006(MySQL server has gone away):SELECT sval FROM wp_parfymeri_se_dfr_xopt WHERE skey='update_lock') ERROR:err_update_lock_failed(pid= m=47754-6cb2ed3012181badbfcdbba3266e54a8) line=152

URL: /index.php
  #2  
Old February 2nd, 2014, 12:28 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

Those errors are sent out when an update is delayed because of too many updates happening at the same time.

If you want you can disable email notifications here:
WordPress Admin Area > Tools > Datafeedr > Debug > Email Notifications

Eric
  #3  
Old February 2nd, 2014, 12:30 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

Forgot to mention that the update will retry later. You don't have to do anything.

Eric
  #4  
Old February 2nd, 2014, 12:47 PM
matzii matzii is offline
 
Join Date: Sep 2013
Posts: 138
Default

ok i understand. But i seems like my temp folder become very full after every update trial.

there are over 100 000 files. Are there any way to set a cron job or something that empty the folder?


/www/webvol3/cl/gx12345678980egh/parfymeri.se/public_html/wp-content/uploads/store/temp
  #5  
Old February 2nd, 2014, 01:01 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

Those temporary files should all be deleted when your store is updated. Those are all cache files.

You can also manually delete them here: WordPress Admin Area > Tools > Datafeedr > Debug > Page cache

Eric
  #6  
Old February 2nd, 2014, 01:11 PM
matzii matzii is offline
 
Join Date: Sep 2013
Posts: 138
Default

in the normal way they are deleted when the store is updated. but it seems like my provider has som database connectione trouble so the updates interrupts and the temp folder become fuller every time i can see how i grows every time.

and the WordPress Admin Area > Tools > Datafeedr > Debug
arent possible to load since it take so long time
  #7  
Old February 2nd, 2014, 01:17 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

You can turn off caching to avoid this issue.

Or you could reduce your packet sizes to 500 here: WordPress Admin Area > Tools > Datafeedr > Updates.

If there are too many files to delete via the Datafeedr interface, you might need to login via FTP and delete the "temp" folder. After it's deleted go here WordPress Admin Area > Tools > Datafeedr > Directories > Temporary Directory check the "Create directory if necessary" checkbox and then click [Save].

Eric
  #8  
Old February 25th, 2014, 02:56 PM
matzii matzii is offline
 
Join Date: Sep 2013
Posts: 138
Default

where can turn off caching ?
  #9  
Old February 25th, 2014, 02:58 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

You can do that here: The Factory > Your Store > Store menu > Advanced Store Settings and uncheck the "Allow view caching" box.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Update error welike Problems 2 November 16th, 2013 09:03 AM
Update Error crewhotspot Questions 7 June 3rd, 2013 07:12 PM
Error Update macfink Problems 1 October 10th, 2012 05:18 AM
Update Error gobigcity Problems 1 March 22nd, 2012 12:28 PM
Update error jganser Problems 4 October 21st, 2011 08:27 AM


All times are GMT -5. The time now is 12:54 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.