Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Questions
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 22nd, 2012, 03:42 PM
kaje kaje is offline
 
Join Date: Mar 2011
Posts: 142
Default Category Custom Content

StoreID:38799

Eric, I was following this post /show...tegory+content so I can add custom content to each category by using php includes.

I used this code
PHP Code:
<?php if ($category->id == 514597) : ?> 
    <?php if (!$_GET) { ?>  
        [store.if page="off"] 
            <?php include("/home/stores/domains/empleous.com/public_html/xxxxx/514597.txt"); ?> 
        [/store.if] 
    <?php ?>
<?php 
endif; ?>
and changed out my category ID as well as the path to my text file. Nothing happens. Am I missing something?
  #2  
Old July 22nd, 2012, 07:57 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

You need to change "/home/stores/domains/empleous.com/" to match your server's settings.

Eric
  #3  
Old July 23rd, 2012, 12:12 AM
kaje kaje is offline
 
Join Date: Mar 2011
Posts: 142
Default

Thanks Eric. I did update the path to reflect /public_html/xxxxx/myid.txt" but it doesn't find it or work. I tried it with the full path as well and it didn't do anything. I've got to be missing something else I'm guessing.
  #4  
Old July 23rd, 2012, 06:22 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Can you go here: WordPress Admin Area > Tools > Datafeedr > Debug > Show Information

Click the [Show] button.

Then scroll down through the information until you get to
Code:
Plugin
----------------
path: /xxxx/xxxx/xxxx/xxxx/wp-content/plugins/datafeedr
Tell me what your site has for "path".

Eric
  #5  
Old July 23rd, 2012, 09:15 AM
kaje kaje is offline
 
Join Date: Mar 2011
Posts: 142
Default

/home/xxxxxxxx/public_html/wp-content/plugins/datafeedr

Last edited by Eric : July 23rd, 2012 at 10:03 AM. Reason: Removed username from path.
  #6  
Old July 23rd, 2012, 09:22 AM
kaje kaje is offline
 
Join Date: Mar 2011
Posts: 142
Default

Eric I got it working. The path was incorrect and you were able to get me to the proper path. Thank you!

One last question. in the text module where I reference this file I'm going to have to put possibly hundreds of references to different text pages. Will that slow down my page? Is there a limit before I'll start seeing the impact of such a large file?
  #7  
Old July 23rd, 2012, 10:03 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

A few hundred references should be fine.

Eric
  #8  
Old September 4th, 2012, 11:26 AM
kaje kaje is offline
 
Join Date: Mar 2011
Posts: 142
Default

Hi Eric, last we spoke this was working. I noticed today that of the 30 instances that I set up and had gotten to work now 16 pages are no longer being referenced by the php include code in the default category view.

I haven't added or removed any plugins and what's even more weird is there are 14 php includes working fine. Any idea what could be causing datafeedr to see some of these and not all of them? When they were originally set up they all worked fine and now they are not. Can you give me any direction that may be causing this?

Thanks

storeID 37038
Working: http://www.personalchecksplus.com/sh.../akita-checks/

Not working: http://www.personalchecksplus.com/sh...errier-checks/
  #9  
Old September 4th, 2012, 11:35 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I would try clearing your cache. That's probably the issue.

Eric
  #10  
Old September 4th, 2012, 02:56 PM
kaje kaje is offline
 
Join Date: Mar 2011
Posts: 142
Default

Thanks Eric. Yeah I've tried clearing the cache in three different browsers and it's still not working.
  #11  
Old September 5th, 2012, 08:51 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

This should be fixed now. Please click the [Update Products and Settings] button on your site.

Eric
  #12  
Old September 5th, 2012, 01:32 PM
kaje kaje is offline
 
Join Date: Mar 2011
Posts: 142
Default

Thanks Eric they are all now back. Was it something I did wrong? What caused these pages to disappear?
  #13  
Old September 5th, 2012, 01:33 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

No, there was a problem on our end.

Eric
  #14  
Old September 5th, 2012, 01:49 PM
kaje kaje is offline
 
Join Date: Mar 2011
Posts: 142
Default

Ok thanks
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unique content on each category homepage digitalcow Questions 15 January 16th, 2014 04:46 PM
Custom content on search results digitalcow Tips, Tricks & Tutorials 2 April 23rd, 2012 02:41 AM
Is it Possible to Merge Category content? twicetime Tips, Tricks & Tutorials 9 January 27th, 2012 02:16 PM


All times are GMT -5. The time now is 01:15 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.