Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Questions
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old May 2nd, 2012, 02:39 PM
kowboy kowboy is offline
 
Join Date: Apr 2012
Posts: 26
Default How To Get Thumbnails To Show?

I have dripped all my products over to WP and into their categories as drafts. I noticed that the posts only display the product if published and as a draft just show the short code. So I published one test post and it looks good. But when I go to the category my excerpt has no thumbnail.

I am using Thesis and have the excerpts for thumbnails plugin installed and the excerpts are set to display as teasers. But this plugin wont display the thumb. My thumbs and product images are directly in the wp content folder and all my directories show a green check. I have confirmed the image for this product is directly in the wp content folder alongside my regular wp images that I uploaded. But it did not show up. I tried uploading directly to the media library, again it did not show and I could not attach it to the post. I have not tried setting it as featured image at this point.

They only way I can get it to show is by inserting the image url into the Thesis post image and thumbnail field. This works but not something I want to repeat 7,000 times. Is there an easier way to get the thumbs to display? Or would it be easier to try to import the view from the factory?

Thanks
Steve
  #2  
Old May 2nd, 2012, 03:36 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

You need to make sure your theme is making a call to the the_content() function on your category pages. If it's making a call to the the_excerpt() function, all HTML is stripped out including your images.

Eric
  #3  
Old May 2nd, 2012, 10:35 PM
kowboy kowboy is offline
 
Join Date: Apr 2012
Posts: 26
Default

Hi Eric,

I am not a coder so I probably got this wrong but using thesis open hook and the thesis_hook_archives_template I tried both of these with no luck.

<?php
global $more; // Declare global $more (before the loop).
$more = 0; // Set (inside the loop) to display content above the more tag.
the_content("More...");
?>


<?php
global $more; // Declare global $more (before the loop).
$more = 1; // Set (inside the loop) to display all content, including text below more.
the_content();
?>

Also tried several other thumbnail generators without luck. I really don't want to have to create each thumbnail manually. Is this code correct and did I do it wrong some how?

Thanks
Steve
  #4  
Old May 3rd, 2012, 08:44 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I would ask the thesis guys this: "How can I display the full content of the posts on the category pages?"

I'm sure there is a way but I really don't know how to do it with Thesis because I don't own the theme.

Eric
  #5  
Old May 3rd, 2012, 11:07 AM
kowboy kowboy is offline
 
Join Date: Apr 2012
Posts: 26
Default

Hi Eric,

Yes I understand it is probably a Thesis issue and actually I have found it really hard to work with but usually there is enough info online to solve my problems.

I have used the thumbnails for excerpts plugin successfully to fix this problem on other sites and with other datafeeds. I guess I will have to do them manually unless I can somehow figure out what is going on.

Thanks
Steve
  #6  
Old May 3rd, 2012, 11:10 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I would recommend asking them the question I posted from above. It should be very easy for them to answer.

If, after you ask them, it's not possible, I still wouldn't do it manually. I would ask them how to use a different custom field to display the images. You said that they have their own custom field for displaying images. I would ask them how to reference a different custom field to pull the images from. Manual is not the way to go...

Eric
  #7  
Old May 3rd, 2012, 12:06 PM
kowboy kowboy is offline
 
Join Date: Apr 2012
Posts: 26
Default

Hi Eric,

Yes I am going to try to find a solution that is not manual. If I cant I am considering changing themes as another option. I actually have found Thesis to be hard to work with and somewhat over rated. There are plenty of themes that automatically generate thumbnails and why a premium theme like Thesis doesn't have this built in is quite frankly beyond me. Right now the site is new and not getting much traffic yet so it would still be relatively easy to make a change now.

Thanks
Steve
  #8  
Old May 3rd, 2012, 10:23 PM
kowboy kowboy is offline
 
Join Date: Apr 2012
Posts: 26
Default

Hi Eric,

By now you should be getting sick of me. Thumbnails are not showing no matter what I try. This is not a Thesis issue the problem is somewhere else.

I have coded thesis to display thumbs and it now does so without the thumbs for excerpts plugin but it wont pull thumbs for dripped posts.

I have tried a different theme that I know generates thumbs from the original and they still do not show.

I have restored my directories to the default and that has not helped either.

My guess is it has something to do with being able to pick up the image in the shortcode. If there is no image to pick up there is no way a thumb can generate.

I found a plugin that is supposed to regenerate thumbs and after scanning all the posts from datafeedr it found no images for any.

So as it stands now if I input the url into thesis or make it a featured image it will show.

I have pretty much run out of ideas to try and don't know what to do next.

If I cant resolve this my only options are to use the store but 7000 products showing up all at once will probably get me deindexed.

The other option is to use csv pig but sorting through all those feeds would probably take longer than inserting the images manually. It is not being well supported cant really update which is why I chose to use Datafeedr.

Steve
  #9  
Old May 4th, 2012, 08:20 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I think the issue is still related to your theme's category pages not using the_content(). If you have a theme or a plugin which handles thumbnails for posts using the_excerpt(), Datafeedr images will still not display. That is because the image is actually in the post and not being pulled from a custom field.

Can you try this:

1. Activate the Twenty-Eleven Theme
2. Go to a category page and check if your thumbnails are showing. They should be.

Eric
  #10  
Old May 4th, 2012, 11:19 AM
kowboy kowboy is offline
 
Join Date: Apr 2012
Posts: 26
Default

Hi Eric,

Yes they show on 2011 and Thesis too for that mater when I display full posts for category archives. So are you are saying the only way to have images appear in categories is to display the full post?

Showing full posts there is bad SEO because it creates duplicate content. I want my categories indexed so I need to show excerpts.

Is there a workaround besides inserting the images manually?

I noticed someone on the forum developed a plugin using tim thumb. Would this work for showing the images in my excerpts?

Thanks
Steve
  #11  
Old May 4th, 2012, 11:36 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

If you are showing the the_excerpt() in your templates, then you can do something like this:

1. Add the following code to your template file which shows the_excerpt(). Make sure to add it within The Loop:

PHP Code:
<?php 
$small_image 
get_post_meta($post->ID'store_thumbnail'); 
$large_image get_post_meta($post->ID'store_image'); 
if (
trim($small_image[0])!='') {
    
$img '<img src="'.$small_image[0].'" width="200" style="float:left;margin:0 10px 10px 0;" />';
} elseif (
trim($large_image[0])!='') {
    
$img '<img src="'.$large_image[0].'" width="200" style="float:left;margin:0 10px 10px 0;" />';
} else {
    
$img '';
}
?>
2. Then place the following code wherever you want the image to appear.
PHP Code:
<?php echo $img?>
For example, here is how my content.php file looks in the 2011 theme:



Eric
  #12  
Old May 4th, 2012, 02:53 PM
kowboy kowboy is offline
 
Join Date: Apr 2012
Posts: 26
Default

Thank you Eric!

I managed to get it working for 2011 at least. I am in so over my head I am not sure if I will be able to make it work for Thesis because their system so different. Like I said I'm not a coder and almost every time I mess with their custom functions I wind up breaking the theme.

Are you familiar with Weaver? It's a highly customizable 2011 theme. So I may be able to make this work with it.

Thanks Again
Steve
  #13  
Old May 4th, 2012, 03:01 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I haven't heard of Weaver.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No Thumbnails/Images bmcoffee Problems 1 January 12th, 2012 12:42 AM
How do I resize my thumbnails? dcutri Problems 4 February 4th, 2011 04:32 PM


All times are GMT -5. The time now is 12:55 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.