Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old November 19th, 2013, 08:58 PM
winnersall winnersall is offline
 
Join Date: Oct 2013
Posts: 20
Default Redbubble Thumbnail Images Not Showing up in Shopper Press

URL to page in question: http://grumpyanimalstore.com/grumpy-...hirts-hoodies/

Hi, I am having an issue with redbubble and having their images show up on shopperpress. Shopperpress support says its a datafeedr problem, cause they feel its the url in the feed. But if you click on the large image, it shows the image.

can you please help. I am using 3.7.1 wordpress, the current datafeedr.

thanks
Jay
  #2  
Old November 19th, 2013, 09:13 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

The Image URL we got from RedBubble is this:

http://ih2.redbubble.net/image.14058...,silver.u2.jpg


The Image URL that is being passed to your site is correct because Datafeedr is processing the image correctly as can be seen here:

http://grumpyanimalstore.com/store/t...7100934724439/

And this is the image hosted locally on your site:



It seems that PP is changing the image URL from this:

Code:
http://ih2.redbubble.net/image.14058040.5262/fc,550x550,silver.u2.jpg
To this:

Code:
http://ih2.redbubble.net/image.14058040.5262/fc550x550silver.u2.jpg
Those missing commas are what is causing the issue.

Eric
  #3  
Old November 19th, 2013, 09:17 PM
winnersall winnersall is offline
 
Join Date: Oct 2013
Posts: 20
Default

Hi Eric,

I saw that too. But how do we fix it? And why would that be happening?

Jay
  #4  
Old November 19th, 2013, 09:19 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

My guess is that SP is stripping out commas (probably inadvertently) from the image URLs. This is not something we can fix. It's something that must be fixed on SP's end.

Eric
  #5  
Old November 20th, 2013, 01:27 AM
winnersall winnersall is offline
 
Join Date: Oct 2013
Posts: 20
Default

Hi Eric,

ShopperPress will not fix the problem. It seems that RedBubble, a merchant from the shareasale program is passing along coma's in the url, which does not work when the script is coma seperated, which is causing the issues. The only way I was able to resolve it was by encoding the comas. Is it possible for Datafeedr to do that in the url's from the data feeds? I would image its best practice when cleaning up the data feeds to not pass comas through for that reason.

Let me know if there is any solution through datafeedr's side.

thanks
Jay
  #6  
Old November 20th, 2013, 09:56 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi Jay,

There's nothing wrong with how RedBubble is supplying its image URLs. Commas are reserved characters for URLs.

An encoded comma could potentially have a different meaning in the URL than an unencoded comma.

Therefore, we can't modify the merchant's URL. We run the risk of breaking a perfectly good URL if we encode it.

Eric
  #7  
Old November 20th, 2013, 11:03 PM
winnersall winnersall is offline
 
Join Date: Oct 2013
Posts: 20
Default

Hi Eric,

I spoke with ShopperPress about this, and they say that its not their problem. That its a datafeedr issue and that there should not be any coma's in the url. I'm at a loss here as the only temporary solution I see is to encode the url's. Are you able to offer any further help on the subject?

thanks
Jay
  #8  
Old November 21st, 2013, 09:57 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi Jay,

Unfortunately there's nothing we can do. I disagree with SP that it's our problem. I don't believe that it is.

The merchant has supplied properly formatted image URLs.

We have imported those URLs into our database as-is.

Our software properly displays those images.

The problem arises when SP attempts to display those images in their system. Up to that point, the image URLs work fine.

For us to get it to work, we would have to modify SP's code, not ours. But we do not do bespoke work so this is not possible.

One last option if SP won't fix this issue is to ask the merchant to remove commas from their image URLs. I don't know if they will or won't but it's worth a try.

Eric
  #9  
Old November 21st, 2013, 10:15 AM
winnersall winnersall is offline
 
Join Date: Oct 2013
Posts: 20
Default

Hi Eric,

thank you for your time and responses regarding this.

Jay
  #10  
Old November 21st, 2013, 10:18 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi Jay,

You're welcome even though I know it's not the answer you're looking for.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thumbnail Images Too Small checkoutoz Questions 5 May 6th, 2013 05:17 PM
Force Thumbnail Images to Never Get Larger Than Set Size? faith Questions 7 August 22nd, 2012 10:54 AM
'Shopper' selects sort order & view all Giftoly Questions 3 February 22nd, 2012 09:20 AM
Shopper Press error - "wp_dfr_shop_products' doesn't exist" redspan Problems 1 July 28th, 2011 11:53 AM


All times are GMT -5. The time now is 10:37 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.