View Single Post
  #9  
Old September 8th, 2013, 01:55 PM
nobin nobin is offline
 
Join Date: Jun 2013
Posts: 18
Default

Hi Eric,

This problem is unfortunately still not solved. I have, however, done a lot of research, and I'm pretty sure that this is not an issue with MySQL, but something with your code.

To illustrate, this works:
http://giftsniffer.com/?s=toe (this uses the WordPress default search, and it correctly returns the two articles containing the word "toe")

Strangely, this works, too:
http://giftsniffer.com/store/search/?description=14k

This does not:
http://giftsniffer.com/store/search/...on=14k+pendant

And neither do these two:
http://giftsniffer.com/store/search/?word=14k
http://giftsniffer.com/store/search/?word=14k+pendant (this returns everything containing "pendant", but ignores "14k")

So "description" works for a single word, even if that word is fewer than four characters. Ergo, the problem lies with DataFeedr.

On a side note, I tried building a workaround that added one or two * (which I presumed would function as a wildcard character) to each word in the search string less than four characters long. This works, but only unpredictably so (many products are omitted that should come back as part of the results). This is still implemented on the site, so I mention it in case you use the search box.

Can you help?

Thank you.

Robin