View Single Post
Old January 22nd, 2011, 04:06 PM
cspdfadmin cspdfadmin is offline
Join Date: Oct 2009
Posts: 20
Default DreamHost "allow_url_fopen" Not Set to True...They Claim Security Risks [Help!!!]

Eric & Stefan,

I ran your v3 plugin requirements by DreamHost tech support today to verify my server compatibility.

"allow_url_fopen" seems to be an issue.

See thread below.

Have you run into this yet with other DreamHost using customers of Datafeedr v3?

Might you help with this as these level of custom server configurations seem a bit advanced?

FYI, I am running a VPS with Dreamhost for my main domain, and my 5 subdomains (the latter of which are my DF v1 stores)


[Chat with DreamHost Tech Support]

Scott: Hello! How can I help you?

Me: Hello, I'm considering purchasing a plugin for my WordPress blog. Before I purchase, I want to make sure that my server meets the requirements of the plugin. 1. Is my server running Linux? 2. Is my server running PHP 5.0 or greater? 3. Is my server running MySQL 5.0.3 or greater? 4. Is the cURL extension installed on my server? If not, is it possible to have it installed? 5. Is the "allow_url_fopen" setting set to true in my PHP configuration file? If not, is it possible to have it set to true? Thank you for your answers to these questions.

Me: If you can answer Yes or No for 1) to 5) that would be helpful!

Scott: 1-4 = Yes. 5=No



Me: But 5 is configurable?

Scott: You can try with a custom php.ini or local install of php.


Me: hmmmm....

Me: that feature is necessary to do regular updates to the plug-in

Scott: Due to it's potential security risks, it's disabled. Being that you are on a VPS, you have more flexibility to overcome's just not something that we can support

Me: what are the security risks?


Me: Any other feedback on it that I can send along to the plug in developers?

Scott: You can quote our wiki: "If a script claims to require this feature, you should look into alternative software, as the use of this feature indicates serious design flaws."

Me: Ok. I will pass this feedback along.

Me: oops...clarifying something with your Yes for 4) above

Me: with 4) cURL is actually installed correct?

Me: I need not do anything with the server on 4) correct?

Scott: #4 correct

Me: curl is installed

Me: 5) is the only issue I have to work through then

Me: right

Scott: Correct

Me: ok...thanks! bye!