Datafeedr Support Forums

Datafeedr Support Forums (/index.php)
-   Questions (/forumdisplay.php?f=67)
-   -   related products not working properly (/showthread.php?t=8967)

dvbmedia April 15th, 2013 07:39 AM

related products not working properly
 
Hello,

A while ago someone of ur team helped us with displaying datafeedr shop products at wordpress articles, back than it worked but it isn't working always.

But at several pages it isn't working anymore, so I was wondering if you could help me.
Also it would be great if we can change the 'keywords' what we currently use (adviced by ur college back than) into the wordpress tags.

Thanks,

Store ID:
Website URL: Tuinkriebels.nl
URL to page in question: http://www.tuinkriebels.nl/tuinonder...vendel-snoeien

Eric April 15th, 2013 09:45 AM

Hi,

This is the post you are referring to: /showthread.php?t=7626

If it's not working, that means either you did not add any keywords, the length of the keywords is less than 4 characters long or there are no products that match those keywords.

If you want to use tags instead of keywords change this line:
PHP Code:

echo datafeedr_tag('ForArticles?word='.$keywords); 

To this:
PHP Code:

echo datafeedr_tag('ForArticles?tags='.$keywords); 

In the code from the post I've linked to above.

Eric

dvbmedia April 15th, 2013 12:25 PM

Hi Eric,

It isn't working..

old script :
Quote:

<?php
$keywords = get_post_meta(get_the_ID(), 'keywords', true);
if ($keywords!= '') {

$product = strip_tags(datafeedr_tag('ForArticles?word='.$keyw ords));
$product = trim($product);

if(!empty($product)){
echo datafeedr_tag('ForArticles?word='.$keywords);
echo'</div>';
}
}
?>
new script
Quote:

<?php
$keywords = get_post_meta(get_the_ID(), 'keywords', true);
if ($keywords!= '') {

$product = strip_tags(datafeedr_tag('ForArticles?word='.$keyw ords));
$product = trim($product);

if(!empty($product)){
echo datafeedr_tag('ForArticles?tags='.$keywords);
echo'</div>';
}
}
?>

or must the first ForArticles? also be tags? (i've tried that to but it still didn't work to be honest)


Also there are still several posts with keywords/tags and they doesn't show any products for example at this link:
http://www.tuinkriebels.nl/tuinonder...vendel-snoeien

you got any suggestions how we can fix this?

Eric April 15th, 2013 12:28 PM

Hi,

What keywords are you using for that article?

Eric


All times are GMT -5. The time now is 01:16 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.