Datafeedr Support Forums

Datafeedr Support Forums (/index.php)
-   Problems (/forumdisplay.php?f=68)
-   -   Sorting Template not displaying right (/showthread.php?t=7290)

daniel_28 July 10th, 2012 01:15 PM

Sorting Template not displaying right
 
1 Attachment(s)
Store ID:
Website URL: www.fitliving.nl
URL to page in question: http://www.fitliving.nl/shop/categor...ess-apparaten/


Hi,

I have a problem with the sorting template above in the category page. It is not displaying correct in IE. I have added a screenshot.

Within Firefox it not displaying at all..

Any suggestions?

thanks!

Eric July 10th, 2012 03:18 PM

Hi

From what I can tell, your theme is adding <br> tags and <p> tags as well as removing necessary <span> tags from the store page.

I tested your site using the 2011 theme and the page looks fine which leads me to believe that it's the theme that's causing the issue, not a plugin.

Here's how it looked with the 2011 theme:



I've tried many things such as removing all line breaks and spaces from the code, turning off the special fonts, removing all CSS other than store CSS, clearing cache, etc... but nothing seems to work.

Can you please ask the theme developer where line break tags (<br>) and paragraph tags (<p>) are being added to the content of a post and how to prevent that from happening?

Eric

daniel_28 July 10th, 2012 03:32 PM

Quote:

Originally Posted by Eric (Post 33419)
Hi

From what I can tell, your theme is adding <br> tags and <p> tags as well as removing necessary <span> tags from the store page.

I tested your site using the 2011 theme and the page looks fine which leads me to believe that it's the theme that's causing the issue, not a plugin.

Here's how it looked with the 2011 theme:



I've tried many things such as removing all line breaks and spaces from the code, turning off the special fonts, removing all CSS other than store CSS, clearing cache, etc... but nothing seems to work.

Can you please ask the theme developer where line break tags (<br>) and paragraph tags (<p>) are being added to the content of a post and how to prevent that from happening?

Eric

Eric, many thanks for your fast reply. I will check the theme developer and will get back to you with his answer.

daniel_28 July 11th, 2012 01:29 AM

Eric,

this is the reply I got from the theme developer.

"
Hi,

Could you try going to include/plugin/shortcode-generator.php file.

At the bottom, try removing these out.

// Remove the 2 main auto-formatters
remove_filter('the_content', 'wpautop');
remove_filter('the_content', 'wptexturize');

// Before displaying for viewing, apply this function
add_filter('the_content', 'webtreats_formatter', 99);
add_filter('widget_text', 'webtreats_formatter', 99);

Hope this helps. :)
"



I am not sure where to adjust this. Must i do this within Datafeedr Factory or in Wordpress. If in wordpress, can you explain where I must adjust this?

many thanks.


Daniel

Eric July 11th, 2012 09:27 AM

Hi

You need to make those changes here: /wp-content/themes/bangkokpress/include/plugin/shortcode-generator.php

I don't have access to that file therefore you will need to make the edits yourself.

Eric


All times are GMT -5. The time now is 01:29 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.