Datafeedr Support Forums

Datafeedr Support Forums (/index.php)
-   Problems (/forumdisplay.php?f=68)
-   -   DFR Short code (/showthread.php?t=6214)

nzcid February 3rd, 2012 06:46 PM

DFR Short code
 
Sotre ID 35319
Web Site URL: http://www.christsbooks.com/featured...erry-macalmon/

Hey Eric and Team

I have used the DFR short like this [DFR product?p=xxxxx] on this page for two products. Issue here is it attempts to show related products.

I like this DFR view not the embeded view. How can I stop the related view section showing without having a effect anywhere else on the site?

Eric February 3rd, 2012 07:43 PM

Hi

You should Duplicate your Product Detail > Default view, rename it to something like "Embedded Product" and then remove the related products module from the new view.

Then you can link to it like this: [DFR Embedded Product?p=xxxxx]

Eric

nzcid February 3rd, 2012 08:16 PM

Quote:

Originally Posted by Eric (Post 28486)
Hi

You should Duplicate your Product Detail > Default view, rename it to something like "Embedded Product" and then remove the related products module from the new view.

Then you can link to it like this: [DFR Embedded Product?p=xxxxx]

Eric

Hey Eric

Thanks - called it something else though as I already have a view like that for the other view of products :)

nzcid February 3rd, 2012 08:42 PM

Quote:

Originally Posted by Eric (Post 28486)
Hi

You should Duplicate your Product Detail > Default view, rename it to something like "Embedded Product" and then remove the related products module from the new view.

Then you can link to it like this: [DFR Embedded Product?p=xxxxx]

Eric

Worked great but the image is huge, not using the thumbnail as it should be:

http://www.christsbooks.com/featured...rian-doerksen/

Eric February 3rd, 2012 09:37 PM

Hi

Go here: The Factory > Your Store > VIEWS > CUSTOM VIEWS > Embedded Product > View menu > View Properties and uncheck the "Don't use layout for this view" checkbox.

Eric

nzcid February 3rd, 2012 10:12 PM

Quote:

Originally Posted by Eric (Post 28491)
Hi

Go here: The Factory > Your Store > VIEWS > CUSTOM VIEWS > Embedded Product > View menu > View Properties and uncheck the "Don't use layout for this view" checkbox.

Eric

Sorry Eric that did not work.

There is a difference between pages

http://www.christsbooks.com/featured...erry-macalmon/

and these two

http://www.christsbooks.com/featured...rian-doerksen/

http://www.christsbooks.com/featured...een-of-heaven/

Yet they are using the same dfr code.

Eric February 4th, 2012 07:07 AM

Hi

In your Custom View > Product Detail view, you should set an image size on your image tag like this:

HTML Code:

<img src="[product.image]" class="thmb1" alt="[product.name]" width="200" />
That should work.

Eric


All times are GMT -5. The time now is 01:28 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.