Datafeedr Support Forums

Datafeedr Support Forums (/index.php)
-   Problems (/forumdisplay.php?f=68)
-   -   Multiple store pages created (/showthread.php?t=3881)

sbanks February 7th, 2011 10:04 AM

Multiple store pages created
 
I am having an odd problem with a couple of my stores. The latest one is: http://factory3.datafeedr.com/feeder/shop?shop=11252

I have set the "store" page to be the home page. Yesterday on this site I noticed two new store pages were created by datafeedr, named:
http://domainnname.org/dfr_store-2/ and
http://domainnname.org/dfr_store/

The dfr_store_2 store page was published and is blank. The dfr_store page says "Missed Schedule" but when you go to edit it the permalink is now http://domainnname.org/dfr_store-2 and when you preview it the page names is http://domainnname.org/dfr_store.

This happened to this site too:
http://factory3.datafeedr.com/feeder/shop?shop=11456

I made made of the store pages a "draft" and so now only one is displaying.

What is causing these extra pages to be created and how do I prevent this?

Thanks,

Susan

Eric February 7th, 2011 10:37 AM

Did you at anytime delete or move to the trash your WordPress "Store" page.
Or did you change the name of the WordPress "Store" page slug?

If you deleted the page or moved it to the trash, this will happen. There must be a WordPress page designated for the store.

If you changed the name of the WordPress "Store" page slug, you will need to update your Advance Store Settings (The Factory > Your Store > Store Menu > Advanced Store Settings) and make sure the Page slug field matches the name on your site.

sbanks February 7th, 2011 02:32 PM

Hi Eric,

I went through several of my stores and checked the settings for both datafeedr and Wordpress. I don't think I deleted the "store" page on any of these sites". (It is possible I might have on one of them when I was having a problem)

All the sites are configured the same. I want the "store" page to be the home page, so on the URL settings in Datafeedr I left the box blank because it said "leave this field balnk to display your store's front page as your blogs home page".

In Wordpress - in Settings -->Reading I set the "Front Page Displays" to the "Store" page. This removes the /store from the store URL.

I am usining Flexibility 3 for all my sites, and there is an option for displaying the "home" page in the navigation, which I have set for "no" so that the "store" page doesn't display twice.

Susan

Eric February 7th, 2011 02:59 PM

Quote:

Originally Posted by sbanks (Post 17747)
In Wordpress - in Settings -->Reading I set the "Front Page Displays" to the "Store" page. This removes the /store from the store URL.

Hi Susan,

This may be the issue, though it's hard to say. You don't have to do this step in order to get the store to appear on the homepage.

Also, what is the slug of your current "Store" page?

If a new page gets created again, can you try to outline the steps that led to that happening?

Eric

sbanks February 7th, 2011 03:48 PM

Hi Eric,

I have changed the Reading settings in Wordpress to "Your latest posts" and will keep and eye on it.

This changes the permalink back to http://domainname.org/store from http://domainname.org.

I will delete all the extra dfr_store pages.

Susan

Eric February 7th, 2011 03:50 PM

Quote:

Originally Posted by sbanks (Post 17755)
This changes the permalink back to http://domainname.org/store from http://domainname.org.

I'm guessing that is a theme setting as the TwentyTen (default WP theme) does not do that. :confused:

sbanks February 7th, 2011 04:40 PM

Oh - that is interesting. Must make it very challenging dealing with all these different themes!


All times are GMT -5. The time now is 01:21 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.