Datafeedr Support Forums

Datafeedr Support Forums (/index.php)
-   Problems (/forumdisplay.php?f=68)
-   -   no merchant logos (/showthread.php?t=3735)

marcaustin January 20th, 2011 11:02 PM

no merchant logos
 
None of my merchant logos are showing in my comparison page

Eric January 20th, 2011 11:07 PM

Hi Marc,

I need more information:

What merchant's are missing logos?
What is the code you are using to display the logos?
What is the URL of the page displaying the comparison page?
What is your store's ID?
Have you configured your Merchant Logo directory here: WordPress Admin Area > Tools > Datafeedr > Web?

Please note that all merchant logos are not yet available. If you need to add some merchant logos now, read this.

Eric

marcaustin January 21st, 2011 12:46 AM

Eric
All merchant logos are missing. Last week when I began setting up comparison pages, all logos were where they were supposed to be and my pages were configured correctly.

I haven't configured any Merchant logo directories because everything was working fine. Only today the logos are gone.

Here is a link to one of my price comparison pages.

http://www.priceritenutrition.com/?q...99700628583488

Eric January 21st, 2011 08:37 AM

Hi

Try this:
  1. Create a Merchant logo directory (could be placed anywhere on your server but probably safest in your wordpress uploads folder. something like: /wp-content/uploads/logos/)
  2. Make it writable (permissions 777)
  3. Update your store by clicking [Update Products and Settings]

Now the merchant logos should be available again.

Eric

marcaustin January 21st, 2011 11:32 AM

Eric
Can you walk me through this a little better.

Eric January 21st, 2011 12:11 PM

Hi

To add a merchant logo directory, do this:
  1. Log into your server via an FTP program
  2. Navigate to /wp-content/uploads/
  3. In the uploads directory create a new directory named "logos"
  4. After the new directory is created, change the permissions on this directory to 777. You can use find the permission settings for a file or directory by right clicking the directory and looking for an option such as "Permissions..." or "Get information" or something like that.
  5. Once your "logos" directory has been created and has the proper permissions, you need to log into your blog and go to WordPress Admin Area > Tools > Datafeedr > Web.
  6. In the "Merchant logo directory" field, input the following path: /wp-content/uploads/logos
  7. Click [Save]
  8. Click the [Update Products and Settings] button. This will load all available logos into the new logos directory that you created.
Now your logos should be appearing on your site.

If you are not comfortable with using an FTP program, you can do the same thing using File Manager which exists in your cPanel which can be found here: yoursite.com/cpanel

Hope that helps,
Eric

digitalcow February 19th, 2011 08:36 AM

Eric, sorry to highjack someone's thread....I have followed the steps you outlined above to create a folder for all my logos, images and thumbnails etc and entered it into the settings. When I run the store update the store updates but not images are saved into my folder.

it is set at 777 permission etc

Eric February 19th, 2011 08:43 AM

The images have to be called before the images will start appearing in your folder.

pnewcomb March 7th, 2011 01:56 PM

Quote:

Originally Posted by Eric (Post 18142)
The images have to be called before the images will start appearing in your folder.

I've done everything you mentioned, and included a call for it in the category list module in my category view. The merchants do have logos available. After I hit the update button in wordpress, nothing shows up in the logo directory at all. What might I be doing wrong?

Actually, now that I think about it, it's probably because it wouldn't know which merchant logo to pull. I have it setup so that each merchant has it's own subcategory, and I want their logo to show up on the parent category page. Would I just have to manually put in a category image for each one?

Eric March 7th, 2011 02:00 PM

You need to make a call to the logo in the Product list module from within the [product.each] / [product.end] tags. Nothing will happen if you make a call to the merchant's logo from within the category list module.

pnewcomb March 7th, 2011 02:39 PM

Quote:

Originally Posted by Eric (Post 18636)
You need to make a call to the logo in the Product list module from within the [product.each] / [product.end] tags. Nothing will happen if you make a call to the merchant's logo from within the category list module.

Ok, that makes sense.

Is there a way I can just get all my current merchant logos put into my directory anyways? Then I'd be able to easily find the image to put into the category image properties.

Eric March 7th, 2011 02:46 PM

Quote:

Originally Posted by pnewcomb (Post 18637)
Is there a way I can just get all my current merchant logos put into my directory anyways?

No, they must first be requested.

pnewcomb March 7th, 2011 03:15 PM

Quote:

Originally Posted by Eric (Post 18638)
No, they must first be requested.

Is there a list of logos somewhere so I can save them manually?

Eric March 7th, 2011 03:23 PM

A lot of the networks have merchant logos. That's where we get a lot of ours.


All times are GMT -5. The time now is 01:03 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.