Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Upgrading from V1 to V3
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 22nd, 2011, 04:06 PM
cspdfadmin cspdfadmin is offline
 
Join Date: Oct 2009
Posts: 20
Default DreamHost "allow_url_fopen" Not Set to True...They Claim Security Risks [Help!!!]

Eric & Stefan,

I ran your v3 plugin requirements by DreamHost tech support today to verify my server compatibility.

"allow_url_fopen" seems to be an issue.

See thread below.

Have you run into this yet with other DreamHost using customers of Datafeedr v3?

Might you help with this as these level of custom server configurations seem a bit advanced?

FYI, I am running a VPS with Dreamhost for my main domain, and my 5 subdomains (the latter of which are my DF v1 stores)

********************

[Chat with DreamHost Tech Support]

Scott: Hello! How can I help you?

Me: Hello, I'm considering purchasing a plugin for my WordPress blog. Before I purchase, I want to make sure that my server meets the requirements of the plugin. 1. Is my server running Linux? 2. Is my server running PHP 5.0 or greater? 3. Is my server running MySQL 5.0.3 or greater? 4. Is the cURL extension installed on my server? If not, is it possible to have it installed? 5. Is the "allow_url_fopen" setting set to true in my PHP configuration file? If not, is it possible to have it set to true? Thank you for your answers to these questions.

Me: If you can answer Yes or No for 1) to 5) that would be helpful!

Scott: 1-4 = Yes. 5=No

Scott: http://wiki.dreamhost.com/CURL

Scott: http://wiki.dreamhost.com/Allow_url_fopen

Me: But 5 is configurable?

Scott: You can try with a custom php.ini or local install of php.

Scott: http://wiki.dreamhost.com/PHP.ini

Me: hmmmm....

Me: that feature is necessary to do regular updates to the plug-in

Scott: Due to it's potential security risks, it's disabled. Being that you are on a VPS, you have more flexibility to overcome it....it's just not something that we can support

Me: what are the security risks?

Scott: http://wiki.dreamhost.com/Allow_url_include

Me: Any other feedback on it that I can send along to the plug in developers?

Scott: You can quote our wiki: "If a script claims to require this feature, you should look into alternative software, as the use of this feature indicates serious design flaws."

Me: Ok. I will pass this feedback along.

Me: oops...clarifying something with your “Yes” for 4) above

Me: with 4) cURL is actually installed correct?

Me: I need not do anything with the server on 4) correct?

Scott: #4 correct

Me: ok....so curl is installed

Me: 5) is the only issue I have to work through then

Me: right

Scott: Correct

Me: ok...thanks! bye!
  #2  
Old January 22nd, 2011, 04:13 PM
cspdfadmin cspdfadmin is offline
 
Join Date: Oct 2009
Posts: 20
Default

Just noticed in your requirements writeup the following:

PHP's cURL extension installed OR allow_url_fopen set to true.

(The last requirement is optional. It's required for automatic & 1-click store updates.)

So, if cURL extension is installed, do I not need to worry that allow_url_fopen is not configured to "True" with Dreamhost.

Can v3 plugin automatic & 1-click store updates work with just cURL extension installed without need for any additional special configuration of the V3 plugin or the server?

Last edited by cspdfadmin : January 22nd, 2011 at 04:15 PM. Reason: additional specificity in last question
  #3  
Old January 22nd, 2011, 04:17 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by cspdfadmin View Post
So, if cURL extension is installed, do I not need to worry that allow_url_fopen is not configured to "True" with Dreamhost.
No.

Quote:
Originally Posted by cspdfadmin View Post
Can v3 plugin automatic & 1-click store updates work with just cURL extension installed without need for any additional special configuration of the V3 plugin or the server?
Yes.

For auto and 1-click updates, you only need either cURL or allow_url_fopen, not both. cURL is preferred.
  #4  
Old January 22nd, 2011, 04:52 PM
cspdfadmin cspdfadmin is offline
 
Join Date: Oct 2009
Posts: 20
Default

Eric. Great! Good to hear.

In order to avoid confusion, might I suggest you adjust the last two questions of your sample web host verification email found here http://www.datafeedr.com/requirements/ to reflect the OR condition of the requirements.
  #5  
Old January 22nd, 2011, 05:44 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Good point! It's been updated to:
Quote:
Hello,

I'm considering purchasing a plugin for my WordPress blog. Before I purchase, I want to make sure that my server meets the requirements of the plugin.

1. Is my server running Linux?
2. Is my server running PHP 5.0 or greater?
3. Is my server running MySQL 5.0.3 or greater?
4. Is the cURL extension installed on my server? If not, is it possible to have it installed?
5. If both answers to question #4 are "No", is the "allow_url_fopen" setting set to true in my PHP configuration file? If not, is it possible to have it set to true?

Thank you for your answers to these questions.
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:16 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.