Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Upgrading from V1 to V3
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 27th, 2011, 08:01 PM
patagonia patagonia is offline
 
Join Date: May 2009
Posts: 506
Default No images when store upgraded from V1 to V3

Eric,

After just upgrading my store... I seem to have no product images on my home page, or any of the pages.

Store id: http://factory3.datafeedr.com/feeder/view?view=3871

Have I set something wrong in the settings?
They were showing a few minutes ago... now they have all disappeared?
  #2  
Old January 27th, 2011, 08:03 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

So, as of today, you now have the option of storing product images and thumbnails locally (ie. on your server). This has many benefits:
  • They can be cached and served faster
  • You don't have to rely on the merchant's server.
  • No possibility of footprinting.
So, I have 2 questions:
  1. Do you want to host all product images on your server?
  2. What version of the plugin are you using?

Eric
  #3  
Old January 27th, 2011, 08:05 PM
patagonia patagonia is offline
 
Join Date: May 2009
Posts: 506
Default

1. Can you tell me how to do both?
2. Just downloaded the latest plugin 30mins ago
  #4  
Old January 27th, 2011, 08:08 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

If you want to host the product images yourself, go to the new Directories section of the Datafeedr plugin and make sure you have those 2 directories (Product Images & Product Thumbnails) set up to accept images. They need to exist and they need to be writable.

Then click [Update Products and Settings]

If you do not want to host the product images, go to the new Directories section of the Datafeedr plugin and delete any paths that exist in the Product Images and Product Thumbnails fields and save each one so that both fields are empty.

Then click [Update Products and Settings]

Eric
  #5  
Old January 27th, 2011, 08:10 PM
patagonia patagonia is offline
 
Join Date: May 2009
Posts: 506
Default

Okay, so I had just done that and noticed that it fixed the images.

HOWEVER:
In the URL Settings in the factory, under product urls: why do I have url paths in there for my thumbnails and images?
What do these settings do?
  #6  
Old January 27th, 2011, 08:16 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by patagonia View Post
In the URL Settings in the factory, under product urls: why do I have url paths in there for my thumbnails and images?
What do these settings do?
Good question.

You can choose to have the URL rewritten but if the images exist on your server, there's really no need in doing so as image URLs are rewritten to hide the fact that the images are being served from merchant sites and not your own.

So, in order to take advantage of having the images hosted on your server, you should set the following URL Settings fields as such:

Product image
/wp-content/uploads/store/products/images/%pi.%pe

Product thumbnail
/wp-content/uploads/store/products/thumbnails/%pi.%pe

That should give you cached, fast loading images with no footprinting or reference to merchants.

Make sure to update your store after you make those changes.

Eric
  #7  
Old January 27th, 2011, 08:31 PM
patagonia patagonia is offline
 
Join Date: May 2009
Posts: 506
Default

Thanks Eric. Can you please (when you get time!) add these new instructions to the Documentation, as that was what I was going through when I upgraded the store.
  #8  
Old January 28th, 2011, 12:17 PM
patagonia patagonia is offline
 
Join Date: May 2009
Posts: 506
Default

Eric, further to this question:
I created the locally hosted images folders on one site and all works fine. However, what if now, I don't want the images hosted locally. I have changed my mind, as they take up too much room.

How can I undo it?

I just went to the Directories section of datafeedr on WP and deleted, saved and updated the store, but they are still pulling from my website.
How do I force it to go back to retrieving images from the merchant?

Thanks
  #9  
Old January 28th, 2011, 12:58 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

First, delete the Product Image and Thumbnail fields on the Directories page.

Then delete the folders (wp-content/store/products/images & wp-content/store/products/thumbnails) from your server.

The reason it looks like they are being pulled from your server is because of the rewriting and your URL settings.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:55 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.