Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Tips, Tricks & Tutorials
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old June 24th, 2012, 03:23 AM
1800HART 1800HART is offline
 
Join Date: Apr 2008
Posts: 487
Default Details button missing when adding FB code

Speaking of LIKE buttons on category page ...

Eric ... I followed the instructions on this discussion thread
http://www.datafeedr.com/forums/show...2894#post32894

I updated my store #930 in the category default view, both text and product modules. It works nice (example: http://hartmarket.com/store/category/pinterest/)

I then replicated CTRL-C/CTRL-V those entire modules (text & product) in all the other stores and while the FB buttons are there, now the Details button is missing and just a text link. Can you see something that I don't see? They are all the same, but you can compare identical codes in store #2898 (example: http://beefjerky.hartmarket.com/stor...y-dehydrators/)

Why doesn't it work? It's the same code in one store copied exactly in the same place as the other store ... and, I have updated store in the datafeedr/tools/plugin/update section

Thanks
HART

// added //
I wonder - if it has anything to do with multisite and subdomains? The #930 is the root and all the others are subdomains
__________________
| Shop @ HART Markets | Twitter |

Last edited by 1800HART : June 24th, 2012 at 03:32 AM.
  #2  
Old June 24th, 2012, 09:05 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Your stylesheet is 404: http://beefjerky.hartmarket.com/file...sets/store.css

Make sure the URL path to the store.css file is configured properly here: WordPress Admin Area > Tools > Datafeedr > Directories > CSS Directory

Eric
  #3  
Old June 24th, 2012, 10:29 AM
1800HART 1800HART is offline
 
Join Date: Apr 2008
Posts: 487
Default

Quote:
Originally Posted by Eric View Post
Hi

Your stylesheet is 404: http://beefjerky.hartmarket.com/file...sets/store.css

Make sure the URL path to the store.css file is configured properly here: WordPress Admin Area > Tools > Datafeedr > Directories > CSS Directory

Eric
Eric .. I'm seeing this on all my sites now - did something change on the upgrade?

These are the settings on HARTmarket.com (root)

Merchant Logos
/wp-content/blogs.dir/1/files/store/merchants

CSS Directory
/wp-content/blogs.dir/1/files/store/assets

Product Images
/wp-content/blogs.dir/1/files/store/products/images


>> I set up directories on all my sites and all used to look like this. However, this is what ALL of them look like now - all the subdomains - overrided since the upgrade to v3.8

Merchant Logos
/files/store/merchants

CSS Directory
/files/store/assets

Product Images
/files/store/products/images

Product Thumbnails
/files/store/products/thumbnails

>> I was able to go into and copy each into the directory e.g. paste /wp-content/blogs.dir/1/files/store/products/images (root site) and change it to /wp-content/blogs.dir/2/files/store/products/images (for beef jerky site) ... but only one at a time to save it. But, then when you come back to the directories and/or hit the "Set up" button it overrides it to these wrong defaults. I'd really hate to have to do that on every store. Is there a way to fix your code?

// added //

It seems to be saving if I SAVE each field individually (4 times) and NOT click the set-up button in the directories section .... At least the field in the Backup directory shows me which blogs.dir/# number it is and I can fix manually. Even the domain mapped domains reverted back to this non-multisite default URL.
__________________
| Shop @ HART Markets | Twitter |

Last edited by 1800HART : June 24th, 2012 at 10:40 AM.
  #4  
Old June 24th, 2012, 10:45 AM
1800HART 1800HART is offline
 
Join Date: Apr 2008
Posts: 487
Default

I just double checked my domain mapped stores ... I didn't notice last night as I bulk'ed edited that facebook code into all category views and then came to each datafeedr plugin settings and updated all settings and then went to first 3 stores and left you above message and went to sleep.

Now - all my domain mapped stores shows me this error:

The domain name you have entered in the Factory does not match this website's domain name. Please log into the Factory and modify your domain name under your store's 'Basic store settings' .. e.g. TurtleLvr.com = shop=38132
__________________
| Shop @ HART Markets | Twitter |
  #5  
Old June 24th, 2012, 11:03 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi
Quote:
Originally Posted by 1800HART View Post
>> I was able to go into and copy each into the directory e.g. paste /wp-content/blogs.dir/1/files/store/products/images (root site) and change it to /wp-content/blogs.dir/2/files/store/products/images (for beef jerky site) ... but only one at a time to save it. But, then when you come back to the directories and/or hit the "Set up" button it overrides it to these wrong defaults. I'd really hate to have to do that on every store. Is there a way to fix your code?

// added //

It seems to be saving if I SAVE each field individually (4 times) and NOT click the set-up button in the directories section .... At least the field in the Backup directory shows me which blogs.dir/# number it is and I can fix manually. Even the domain mapped domains reverted back to this non-multisite default URL.
You will have to manually set up those directories for each store. Clicking the [Set up] simply tries to guess the appropriate directories but there's no guarantee that it will be correct.

Quote:
Originally Posted by 1800HART View Post
The domain name you have entered in the Factory does not match this website's domain name. Please log into the Factory and modify your domain name under your store's 'Basic store settings' .. e.g. TurtleLvr.com = shop=38132
Can you try entering this as the domain name: turtlelvr.hartmarket.com

Eric
  #6  
Old June 24th, 2012, 11:12 AM
1800HART 1800HART is offline
 
Join Date: Apr 2008
Posts: 487
Default

Quote:
Originally Posted by Eric View Post
HiYou will have to manually set up those directories for each store. Clicking the [Set up] simply tries to guess the appropriate directories but there's no guarantee that it will be correct.


Can you try entering this as the domain name: turtlelvr.hartmarket.com

Eric
I will manually set up the directories - again. It definitely has reverted to the default and changed all my existing settings during this upgrade. I can confirm that - because I documented everything in my AZZfile "how-to" reminder notes. / FYI (wasn't me!)


As for the domain mapped domains - reverting to its subdomain url worked for turtlelvr.com and my other mapped domains to e.g. back to turtlelvr.hartmarket.com works / thanks.
__________________
| Shop @ HART Markets | Twitter |
  #7  
Old June 24th, 2012, 11:19 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi
Quote:
Originally Posted by 1800HART View Post
I will manually set up the directories - again. It definitely has reverted to the default and changed all my existing settings during this upgrade. I can confirm that - because I documented everything in my AZZfile "how-to" reminder notes. / FYI (wasn't me!)
Because of all of the changes we needed to make to the plugin in order for it to support domain mapping, I do not doubt you. It is very complicated and difficult to develop for.

Eric
  #8  
Old June 24th, 2012, 11:56 AM
1800HART 1800HART is offline
 
Join Date: Apr 2008
Posts: 487
Default

One final question ...

I noticed that while the Backup directories shows up as:
/home/market/public_html/wp-content/blogs.dir/52/files/store/backups (etc)

All the Temporary Directories remain as ....
/tmp

I never documented if this was changed or not - should I update that to something else? I don't even have a /tmp folder anywhere in my hartmarket.com domain, yet alone in any of the individual blogs.dir/ folders. Could that be partly responsible for the slow loading?

Maybe I should create something like...
/home/market/public_html/wp-content/blogs.dir/7/files/store/tmp ???
__________________
| Shop @ HART Markets | Twitter |
  #9  
Old June 24th, 2012, 11:58 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

If you are not having problems updating your website, then don't change the temporary directory. It only requires changing when updates are failing or page caching is not working.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Facebook Like Button - Adding a like button to your product detail pages Eric Tips, Tricks & Tutorials 35 November 25th, 2014 10:22 AM
Facebook Like Button - Adding a like button to your store's front page Eric Tips, Tricks & Tutorials 2 March 13th, 2014 06:23 PM
Facebook Like Button - Adding a like button to each product on the category page Eric Tips, Tricks & Tutorials 5 June 24th, 2012 05:14 PM
coupon code in product details page jcvm27 Problems 5 January 10th, 2012 01:17 PM


All times are GMT -5. The time now is 02:31 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.