Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old May 25th, 2011, 08:45 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default Update Fail: ERROR: curl_error

We've had a few members getting curl_errors after upgrading to version 3.2. We are still trying to work out what exactly the issue is but it seems to be related to DNS settings. All users with this problem seem to be using HostGator.

Anyway, if you are having this issue, we've put in place a temporary solution.
  1. Upgrade the Datafeedr plugin to version 3.2.3264 (or greater).
  2. Go here: WordPress Admin Area > Tools > Datafeedr > Debug.
  3. Scroll to the bottom of the page.
  4. Under "Factory host", replace "factory3.datafeedr.com" with "75.101.166.188" (without the double quotes) then click [Save].
  5. Then click the [Update Products and Settings] button.

Now your store should successfully update.

If you still receive this error after following these steps, please post in this thread with your error message and web host name.

Eric
  #2  
Old May 29th, 2011, 12:29 PM
trishmullen trishmullen is offline
 
Join Date: May 2011
Posts: 34
Default

I too am with HostGator and received the curl_error message. I checked DNS, CPanel details etc and everything seems to be in order.

At Step 4, I couldn't see "Factory host", replace "factory3.datafeedr.com" with "75.101.166.188" (without the double quotes) then click [Save]. I didn't have this option at the bottom of the page.

I left out Step 4 and just followed Step 5 and miraculously it worked. It just seemed to need deactivating and reactivating of the plug-in to get things going.

Thanks
Trish
  #3  
Old May 30th, 2011, 12:56 PM
milknhoney milknhoney is offline
 
Join Date: Feb 2010
Posts: 31
Default

It is starting to look like this is a problem with AT&T Uverse and not hostgator. I was holding hostgator's feet to the flame so to speak and this is the final email that I received:

Quote:
Looking over your network trace it looks like a transit point between AT&T and The Planet Datacenter is experiencing latency issues.

I ran a MTR back to you from the server:

[root@gator789 ~]# mtr -c 100 --report 99.66.52.49
gator789.hostgator.com Snt: 100 Loss% Last Avg Best Wrst StDev
41.0.78ae.static.theplanet.com 0.0% 3.0 4.3 0.3 79.5 9.5
po212.dsr01.dllstx2.networklayer.com 0.0% 0.4 24.9 0.3 202.3 51.4
te2-1.dsr01.dllstx3.networklayer.com 0.0% 3.0 4.3 0.6 186.8 19.2
e4-2.ibr03.dllstx3.networklayer.com 0.0% 2.2 3.4 0.4 16.6 4.2
xe-0-5-0-4.r07.dllstx09.us.bb.gin.ntt.net 0.0% 3.4 1.8 0.6 10.0 2.3
ae-1.r08.dllstx09.us.bb.gin.ntt.net 0.0% 4.7 2.0 0.6 16.1 3.0
ex1-tg7-0-0.eqdltx.sbcglobal.net 0.0% 10.0 8.4 0.6 77.4 18.4
12.123.150.50 0.0% 40.0 37.2 36.0 45.8 1.9
??? 100.0 0.0 0.0 0.0 0.0 0.0
75.26.64.13 90.0% 52.8 42.0 36.6 52.8 5.6
75.26.64.25 99.0% 47.1 47.1 47.1 47.1 0.0
??? 100.0 0.0 0.0 0.0 0.0 0.0


As you can see there is major packet loss on the AT&T side of the network. I suggest you contact your ISP and forward them this data. I hope this is temporary for you and I wish there is more that I could do, but unfortunately this is intermittent and outside of our network.
I contacted AT&T as well as the planet datacenter. AT&T does not want to admit that there is a problem with their network. I'm not giving up but I think I have taken this as far as it can go based on my extremely limited knowledge of these things. I hope it works itself out soon. Just wanted to let you guys know that the people that are having problems with hostgator may also have AT&T Uverse as their ISP and that is the real issue here.

Hope this helps and I hope these issues get worked out soon,

Dave
  #4  
Old July 6th, 2011, 05:57 PM
sloughmiller sloughmiller is offline
 
Join Date: Jul 2011
Posts: 16
Default

Hello Milknhoney,

I too am having issues with a node on an ISP network dropping packets (Cox Communications). What I did was call Technical Support, and request to speak to the supervisor. I was armed with a trace on the network that pointed directly to the faulty node in their network. What I did was call Hostgator, and opened a trouble ticket. They made sure my site was not experiencing any server load problems, by performing all kinds of tests. There were none so they then recommended I run a report using PingPlotter, and send them the report; they in turn provided me with the link describing the node, which was shown in the report as dropping the packets- I pleaded with the supervisor at Cox to please take a look at the link I had, where on this network-tools.com/.. it supplied the NetRange, CIDR, OriginAS, NetName, NetHandle, Parent, OrgName, and so forth. At that point, the supervisor was convinced and requested that link of mine, and promised to escalate the issue to data engineering. Additionally, the modem did not meet their requirements (tested) with regard to speed so they will be out tomorrow to test and possibly replace it.

I hope this issue is over with soon; I know what you mean. It's enough to drive you crazy.

Also, if you choose to follow the same approach I did, make sure you get the supervisor's name (first and last), and his/her phone number for a follow up!!! Tell him or her you are a Web Developer and you have a deadline to meet; that a good connection is CRITICAL!!! You want to hold them to their quality of service agreement with you!!

Good luck!
Sandra
  #5  
Old May 30th, 2011, 12:59 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi Dave

Thanks for sharing this valuable information! We really appreciate it.

Eric
  #6  
Old May 30th, 2011, 06:27 PM
TheBayLady TheBayLady is offline
 
Join Date: May 2011
Posts: 9
Default Factory Host defaulting back to factory3.datafeedr.com

Just wanted to let you know that I had trouble with the latest update, and so checked the debug file, and found that the store had defaulted back to the factory3 settings. Weird. I just reinserted the 75.101.166.188 and it is updating just fine again.

Also, I don't think I use AT&T Uverse, I am on Comcast. Could be the same - I don't know.

Love you guys though. You are definitely on the ball!

Roxie
  #7  
Old May 31st, 2011, 03:01 AM
fashion fashion is offline
 
Join Date: May 2011
Posts: 24
Default

HI.

This is working for me, with powerhosting.dk

Thank you
  #8  
Old June 10th, 2011, 03:41 PM
trishmullen trishmullen is offline
 
Join Date: May 2011
Posts: 34
Default

Quote:
Originally Posted by Eric View Post
We've had a few members getting curl_errors after upgrading to version 3.2. We are still trying to work out what exactly the issue is but it seems to be related to DNS settings. All users with this problem seem to be using HostGator.

Anyway, if you are having this issue, we've put in place a temporary solution.
  1. Upgrade the Datafeedr plugin to version 3.2.3264 (or greater).
  2. Go here: WordPress Admin Area > Tools > Datafeedr > Debug.
  3. Scroll to the bottom of the page.
  4. Under "Factory host", replace "factory3.datafeedr.com" with "75.101.166.188" (without the double quotes) then click [Save].
  5. Then click the [Update Products and Settings] button.

Now your store should successfully update.

If you still receive this error after following these steps, please post in this thread with your error message and web host name.

Eric
This worked for me after I received a similar email to others here in the forum and I am with HostGator. I changed the settings in debug to 75.101.166.188 and it updated no problem.

Do I leave this setting or change it back? If I leave it does that mean that from now on the automatic updates will work or will I need to keep updating manually please?

Thanks
Trish
  #9  
Old June 10th, 2011, 03:45 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi
Quote:
Originally Posted by trishmullen View Post
Do I leave this setting or change it back? If I leave it does that mean that from now on the automatic updates will work or will I need to keep updating manually please?
You can just leave it as is. Your automatic updates will work just fine.

Eric
  #10  
Old June 10th, 2011, 04:04 PM
trishmullen trishmullen is offline
 
Join Date: May 2011
Posts: 34
Default

Thank you Eric, so that part now I can 'set and forget'

Trish
  #11  
Old June 26th, 2011, 05:42 PM
thenarrowshoe thenarrowshoe is offline
 
Join Date: Aug 2009
Posts: 186
Default Is this the same error?

Eric,

I'm getting this also and I'm with hostgator as well:

ERROR: - Cannot download store data (curl_error),
Technical details:
drip: auto_check returned 2
ERROR: drip: failed: no products ()

What exactly does this mean?

Thanks!
  #12  
Old June 26th, 2011, 06:10 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

It's a DNS issue that members are having while using HostGator hosting. We're still not sure exactly what the problem is but applying the steps in the first post of this thread has worked for everyone. Also, make sure your plugin is up to date and if it's not, update the Datafeedr plugin and then run a full update by clicking the [Update Products and Settings] button.

Eric
  #13  
Old July 6th, 2011, 05:33 PM
sloughmiller sloughmiller is offline
 
Join Date: Jul 2011
Posts: 16
Default

Hello Everyone,

If you are a Hostgator customer, CURL is disabled by default! Give them a ring to enable it for you. You must enable for each domain on which you are working with Datafeedr.

Good luck!
Sandra
  #14  
Old August 16th, 2011, 07:48 PM
teeshirtdrama teeshirtdrama is offline
 
Join Date: Mar 2009
Posts: 50
Default

I am getting the same error. I use Rochen not Host Gator. I tried doing the debug thing but I still seem to be getting those error emails. Any other fixes?
  #15  
Old August 16th, 2011, 08:34 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by teeshirtdrama View Post
I am getting the same error. I use Rochen not Host Gator. I tried doing the debug thing but I still seem to be getting those error emails. Any other fixes?
Please post your full error.
  #16  
Old August 16th, 2011, 08:44 PM
teeshirtdrama teeshirtdrama is offline
 
Join Date: Mar 2009
Posts: 50
Default

1. his is to inform you that the automatic update on your website (www.totallyt-shirts.com) has failed. Please see the error message(s) below:

ERROR: - Store data cannot be read,
Technical details:
DRIP: 1313546817 1313540038 10800
drip: auto_check returned -2
bgupdate: BEGIN (ok:1:89:33260)
bgupdate: send (wait:2:89:33260)
download: using curl (http://75.101.166.188/feeder/remote_...ebb69bdb1d013b)
download: done (79)
ERROR: bad_download (bad_header) error:871,call.updater.read_shop_update_chunk:764, bgupdate:0,call_user_func_array:864,call..bgupdate :3708
bgupdate: memory: 0 time: 0.081
bgupdate: FAILED
auto_update: err_read:bad_download

2. This is to inform you that the automatic update on your website (www.totallyt-shirts.com) has failed. Please see the error message(s) below:

ERROR: - Cannot download store data (curl_error),
Technical details:
DRIP: 1313546817 1313540964 10800
drip: auto_check returned -2
bgupdate: BEGIN (ok:38:89:33265)
bgupdate: send (wait:39:89:33265)
download: using curl (http://75.101.166.188/feeder/remote_...769b09deb0420e)
ERROR: curl_error (couldn't connect to host(7)) error:871,call.updater.download_shop_update_chunk: 760,bgupdate:0,call_user_func_array:864,call..bgup date:3708
bgupdate: memory: 0 time: 188.973
bgupdate: FAILED
bgupdate: FAIL: download error
auto_update: err_download:curl_error
  #17  
Old August 19th, 2011, 08:32 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Can you PM me the following information:

BLOG LOGIN INFO with ADMINISTRATOR PERMISSIONS (Temporary login information preferred)
Admin URL:
Username:
Password:

FTP LOGIN INFORMATION (Temporary login information preferred)
Host:
Login:
Password:

Thanks,
Eric
  #18  
Old August 31st, 2011, 03:51 PM
iriegirl iriegirl is offline
 
Join Date: Aug 2011
Posts: 9
Default

I got this message from hostgator recently. I have no idea what it means or what to do.

This is to inform you that the automatic update on your website (halloweencostumes-onsale.net) has failed.

Please see the error message(s) below: ERROR: - Store data cannot be read (mysql),Technical details:track: added referer=(http://www.google.com/imgres?q=slutt...:0&tx=46&ty=63) id=(746)bgupdate: BEGIN (ok:2:3:39365)bgupdate: send (wait:3:3:39365)download: using curl (http://factory3.datafeedr.com/feeder...55af)download: done (14369)ERROR: mysql: MySQL server has gone away(2006) [INSERT IGNORE INTO wp_dfr_shop_tags_tmp(name,pc,freq) VALUES ('bat',10,1), ('bats',4,0), ('wee',1,0)] () error:871,call.updater.read_shop_update_chunk:764, bgupdate:0,call_user_func_array:864,call..bgupdate :3703bgupdate: memory: 0 time: 59.142bgupdate: FAILEDauto_update: err_read:mysql: MySQL server has gone away(2006) [INSERT IGNORE INTO wp_dfr_shop_tags_tmp(name,pc,freq) VALUES ('bat',10,1), ('bats',4,0), ('wee',1,0)]
  #19  
Old September 6th, 2011, 04:05 PM
redspan redspan is offline
 
Join Date: Feb 2009
Posts: 83
Default

Hello,

I'm having to replace the domain name with the IP address in each site. I've tried three or four so far.

All my sites are with Rackspace Cloud

Just FYI...
  #20  
Old August 16th, 2011, 09:56 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Please try these steps: http://www.datafeedr.com/forums/show...oad+bad_header

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot download store data (curl_error) dcutri Problems 11 May 24th, 2011 09:50 AM
ERROR: - automatic update not working? JustDK Problems 2 May 13th, 2011 10:29 AM
Cannot download store data (curl_error) meperez Problems 2 May 2nd, 2011 09:15 PM
shop_update: FAIL: locked / err_au_locked Eric Problems 37 April 4th, 2011 03:51 PM


All times are GMT -5. The time now is 11:58 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.