Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old August 17th, 2011, 01:08 PM
dcutri dcutri is offline
 
Join Date: Nov 2010
Posts: 75
Default The factory is painfully slow for me

I have read in here that not everyone has this problem, but can anything be done to solve it, or does anyone have any suggestions, advice, tips, or anything? The factory is PAINFULLY slow for me. I have one large category with only about 1,500 products. I plan on using all filters instead of subcategories, but every time I save a search or copy a search it takes so long that it is ruining my day. It's almost impossible to work with. Even just opening up the store category page takes forever. I need help. I can't imagine what it will be like when I have tens of thousands of products. It's not my PC, and it's not my browser, as far as I know. I have no other problems with any other programs, web applications, etc. What can I do? Anything? Please tell me there's some trick I can try. Not to whine, but I've been putting up with it for a long time thinking maybe something will change on its own (wishful thinking). I'm spending a lot of money and wasting a lot of time. Anybody?

Last edited by dcutri : August 17th, 2011 at 01:19 PM.
  #2  
Old August 17th, 2011, 01:24 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

What operating system and version are you using?
What browser and version are you using?

What's the store ID and category ID?

Eric
  #3  
Old August 17th, 2011, 01:27 PM
dcutri dcutri is offline
 
Join Date: Nov 2010
Posts: 75
Default

If it's any help to those who might be searching for a clue or a solution to this problem: it seems that whatever I am trying to do in the factory actually IS being done reasonably quickly, it's just that my browser doesn't know it? The page will appear to be loading, and loading, and loading, but in reality whatever task I am trying to accomplish is already done. I know this because I have closed windows that were taking too long to load, before they finished loading, and then the next time I log into the factory it's there (the thing which never finished loading for me, whether is a saved subscription, or a copy of a saved subscription--does that make sense?). Of course, this doesn't help me solve the problem, but I thought maybe someone might understand what's going on better than I do.
  #4  
Old August 17th, 2011, 01:33 PM
dcutri dcutri is offline
 
Join Date: Nov 2010
Posts: 75
Default

I'm using Windows 7 and the latest version of the Factory (3.2.3316). I've tried all these browsers--Firefox 5.0.1, Safari 5.1, Chrome 13, IE8, and Opera 11.

Store ID: 32694
Category ID: 620599
  #5  
Old August 17th, 2011, 02:01 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

The issue was your search subscriptions. You had created 79 search subscriptions. Therefore, everytime you loaded the category, you performed at least 79 individual and complex searches on the database. That is what was taking so long to load.

I re-created all of your 79 subscriptions into 1 subscription. You can see it set up under the "TEST" category in your store. It still takes a couple of seconds to load because the query is still quite complex, but there is only 1 query instead of 79.

Check it out and let me know if you have any questions. I used most of what you used but set up the price filter to quickly and efficiently filter out products that, based on price, do not match your category niche.

Eric
  #6  
Old August 17th, 2011, 04:23 PM
dcutri dcutri is offline
 
Join Date: Nov 2010
Posts: 75
Default

I understand. That's about 1,000 times better. Thank you! Just a couple of questions:

When I do decide to add another artist to the list, how am I going to know that the products it finds are acceptable to me? They are put in order by merchant, which scatters them all over the place. And it never shows all of them. Right now it says there are 1,472 products but it's only showing the 900 "most relevant" ones. If they're not relevant, why include them? If they are relevant, why not show them? Or show them all to me so I can decide if they're relevant. Know what I mean?

Last edited by dcutri : August 17th, 2011 at 04:30 PM.
  #7  
Old August 17th, 2011, 05:11 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I guess you will always have some issues with this method of building a store as it's not exactly how we built the search form to be used. I think in most cases, each artist would be its own category. So I think it's going to be hard to know that all of the products you find will be acceptable.

The "1,472 products (showing 900 most relevant ones)" part is there to indicate that 572 duplicates were excluded because you have 'exclude duplicates' checked.

Eric
  #8  
Old August 17th, 2011, 06:31 PM
dcutri dcutri is offline
 
Join Date: Nov 2010
Posts: 75
Default

Thank you. I knew I was taking the whole filter thing a bit too far!
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Painfully slow page load times milknhoney Problems 5 May 29th, 2011 08:19 PM


All times are GMT -5. The time now is 07:50 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.