Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 19th, 2011, 10:29 PM
ayorofrance ayorofrance is offline
 
Join Date: Sep 2010
Posts: 430
Default Product Count not working

Hi Eric,

I'm playing with the product count, but I can't seem to get it to work.

I've tried:
Code:
[category.list before='<ul>' after='</ul>']
    
  [category.if active='self']
    <li>
      <strong><a href="[category.link]" title="[category.name]">[category.name] ([category.count total='no'])</strong></i>
      [category.repeat]
    </li>
  [/category.if]
  
  [category.if active='child']
    <li>
      <a href="[category.link]" title="[category.name]">[category.name] ([category.count])</a>  
      [category.repeat]
    </li>
  [/category.if]
  
  [category.if active='parent']
    <li>
      <a href="[category.link]" title="[category.name]">[category.name] ([category.count total='no'])</a>  
    </li>
  [/category.if]
  
  [category.if active='no']
    <li>
      <a href="[category.link]" title="[category.name]">[category.name] ([category.count total='no'])</a>
    </li>
  [/category.if]
    
[/category.list]
But both variations give me a zero count in the child categories as you can see on the screenshot...

Shop id: http://factory3.datafeedr.com/feeder/shop?shop=30208

I've PM'ed you the shop URL...

Cheers,

Anders
__________________
WordPress Security - Is your WordPress secure? Get our FREE checklist and find out.

Easy-Email - Access ALL your email accounts with one login & synchronize automatically on all your computers.
  #2  
Old January 19th, 2011, 10:31 PM
ayorofrance ayorofrance is offline
 
Join Date: Sep 2010
Posts: 430
Default

Forgot the image...
Attached Thumbnails
Click image for larger version

Name:	datafeedr - product count.png
Views:	104
Size:	33.2 KB
ID:	365  
__________________
WordPress Security - Is your WordPress secure? Get our FREE checklist and find out.

Easy-Email - Access ALL your email accounts with one login & synchronize automatically on all your computers.
  #3  
Old January 20th, 2011, 09:01 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

What version of the plugin are you using?
  #4  
Old January 20th, 2011, 10:48 AM
ayorofrance ayorofrance is offline
 
Join Date: Sep 2010
Posts: 430
Default

3.02.2946
__________________
WordPress Security - Is your WordPress secure? Get our FREE checklist and find out.

Easy-Email - Access ALL your email accounts with one login & synchronize automatically on all your computers.
  #5  
Old January 20th, 2011, 10:54 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Try clicking [Update Products and Settings] and see if that updates the counters.
  #6  
Old January 20th, 2011, 11:05 AM
ayorofrance ayorofrance is offline
 
Join Date: Sep 2010
Posts: 430
Default

Sorry, it didn't...
__________________
WordPress Security - Is your WordPress secure? Get our FREE checklist and find out.

Easy-Email - Access ALL your email accounts with one login & synchronize automatically on all your computers.
  #7  
Old January 20th, 2011, 11:15 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

I think the problem is in your code. You need to change all occurrences of "[category.count total='no']" to just "[category.count]".

Also, you have an orphaned </i> tag.

Eric
  #8  
Old January 20th, 2011, 11:49 AM
ayorofrance ayorofrance is offline
 
Join Date: Sep 2010
Posts: 430
Default

Thanks for looking at this...

I changed the code to:
Code:
[category.list before='<ul>' after='</ul>']
    
  [category.if active='self']
    <li>
      <strong><a href="[category.link]" title="[category.name]">[category.name] ([category.count])</strong>
      [category.repeat]
    </li>
  [/category.if]
  
  [category.if active='child']
    <li>
      <a href="[category.link]" title="[category.name]">[category.name] ([category.count])</a>  
      [category.repeat]
    </li>
  [/category.if]
  
  [category.if active='parent']
    <li>
      <a href="[category.link]" title="[category.name]">[category.name] ([category.count])</a>  
    </li>
  [/category.if]
  
  [category.if active='no']
    <li>
      <a href="[category.link]" title="[category.name]">[category.name] ([category.count])</a>
    </li>
  [/category.if]
    
[/category.list]
Updated products and settings, emptied caches and still no luck...
__________________
WordPress Security - Is your WordPress secure? Get our FREE checklist and find out.

Easy-Email - Access ALL your email accounts with one login & synchronize automatically on all your computers.
  #9  
Old January 20th, 2011, 11:56 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

This is a new bug. We are looking into this.
  #10  
Old January 20th, 2011, 12:00 PM
ayorofrance ayorofrance is offline
 
Join Date: Sep 2010
Posts: 430
Default

Ok, so you won't need the user I just created for you ;-)
__________________
WordPress Security - Is your WordPress secure? Get our FREE checklist and find out.

Easy-Email - Access ALL your email accounts with one login & synchronize automatically on all your computers.
  #11  
Old January 20th, 2011, 12:01 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

No, but thanks!
  #12  
Old January 31st, 2011, 09:31 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Product count has been fixed as of version 3.02.2985.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:47 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.