Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old June 23rd, 2012, 11:07 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default 1100+ 404 error messages related to my Dayafeedr store

Hello,

When I started using Datafeedr I liked that there is so much to customize. To avoid potential duplicate content issues, I followed, no indexed all of my categories. I thought that would carry over from my categories (parent/child) to all of the individual items pulled into my store, thereby also avoiding a dup content issue with whatever individual products are pulled form my saved searches. I didn't think about how the items that are dropped from my store or no longer available in my saved searches would be treated. I have my saved searches updating every 3 days. Figured they would follow the parent/child deal.

1. Tonight I looked at my webmaster tools and found over 1100 404 error messages, almost all related to my store. Additionally I've noticed over 10,000 canonical notices from SEO Moz.

1. How do I remove all of those 404 error messages? Do I need to update my Yoast SEO site map? Do I have to no index no follow my entire store page?

2. Since I have my store refreshing every 3 days, if Google indexes or follows those individual items that are dropped or no longer available how can I get Datafeedr to replace those dead items?

3. If I have to no follow, no index all of my categories and every individual item for sale, how can I do any SEO on those items?

Thank You,

Michael

Store ID: 37187
Website URL: www.synergybyjasmine.com
URL to page in question: www.synergybyjasmine.com/store
  #2  
Old June 24th, 2012, 08:59 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi
Quote:
Originally Posted by synergybyjasmine View Post
1. Tonight I looked at my webmaster tools and found over 1100 404 error messages, almost all related to my store.
I think there is a major conflict between Datafeedr and another plugin you have installed. Have you installed any redirect plugins or any type of plugin that may manipulate the URLs of your website?

Quote:
Originally Posted by synergybyjasmine View Post
Additionally I've noticed over 10,000 canonical notices from SEO Moz.
Yes, I see you have added a canonical link to your homepage on most/all of your pages. This is very bad. I'm not sure what plugin is doing that (it's not Datafeedr as we do not add canonical links to the <head> elements) but it should be removed. It might even be your theme.

Quote:
Originally Posted by synergybyjasmine View Post
1. How do I remove all of those 404 error messages? Do I need to update my Yoast SEO site map? Do I have to no index no follow my entire store page?
The 404s will be removed once we find where the conflict is happening. No indexing and no following for your entire store is up to you. I'm not sure why you'd want to do that but it is possible.

Quote:
Originally Posted by synergybyjasmine View Post
2. Since I have my store refreshing every 3 days, if Google indexes or follows those individual items that are dropped or no longer available how can I get Datafeedr to replace those dead items?
You need to submit a store sitemap to Google. I've posted how to set up a store sitemap in this thread: http://www.datafeedr.com/forums/show...9840#post29840

Quote:
Originally Posted by synergybyjasmine View Post
3. If I have to no follow, no index all of my categories and every individual item for sale, how can I do any SEO on those items?
You can't. Like I said, I'm not sure why you'd want to nofollow/noindex all of your store pages.

Please let me know what plugins you have activated on your site. I really think that is the cause for all of these problems.

Eric
  #3  
Old June 25th, 2012, 09:45 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Eric,

I think the issue might be Yoast Analytics (which I do have custom tracking for off-page events) or my WP theme Headway Theme. I've included a list of plugins I am currently using , and site stats;

PLUGINS
BackupBuddy
Version 2.2.28 | By The PluginBuddy Team | Visit PluginBuddy.com | Check for Updates Now

Calendar
Version 1.3.1 | By Kieran O'Shea | Visit plugin site

Datafeedr
Version 3.6.4006 | By Datafeedr | Visit plugin site

Easy Facebook Like Button
Version 1.02 | By jonefox | Visit plugin site

Google Analytics for WordPress
This plugin makes it simple to add Google Analytics to your WordPress blog, adding lots of features, eg. custom variables and automatic clickout and download tracking.
Version 4.2.4 | By Joost de Valk | Visit plugin site

Pretty Link Lite
Version 1.6.0 | By Caseproof | Visit plugin site

SEO Slugs
Removes common words like 'a', 'the', 'in' from post slugs to improve SEO.
Version 1.0 | By Andrei Mikrukov | Visit plugin site

ServerBuddy
Various tools & tests to analyze server configuration & troubleshoot issues. Navigate to Tools: ServerBuddy. By PluginBuddy.com.
Version 1.0.2 | By Dustin Bolton | Visit PluginBuddy.com

WordPress SEO
The first true all-in-one SEO solution for WordPress, including on-page content analysis, XML sitemaps and much more.
Version 1.2.3 | By Joost de Valk | Visit plugin site

WP Show IDs
Simple, yet elegant. Shows IDs for Posts, Pages, Media, Links, Categories, Tags, and Users in the admin tables for easy access. Very lightweight. Also supports Custom Post Types / Taxonomies.
Version 110709 | By PriMoThemes.com / WebSharks, Inc. | Visit plugin site

WP Super Cache
Very fast caching plugin for WordPress.
Version 1.1 | By Donncha O Caoimh | Visit plugin site

SITE STATS
Headway Version: 2.0.13
WordPress Version: 3.4
PHP Version: 5.2.17
MySQL Version: 5.1.63-community-log
Web Server Info: Apache
Browser Info: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5
PHP cURL Support: Yes
PHP GD Support: Yes
PHP Memory Limit: 256M
PHP Post Max Size: 10M
  #4  
Old June 25th, 2012, 09:49 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Could you disabling one by one the following plugins to see if they are in conflict with Datafeedr:

- Yoast Analytics
- SEO Slugs
- WordPress SEO

Also, make sure you clear your cache before each test.

Eric
  #5  
Old June 25th, 2012, 10:11 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Eric,

We are primarily a local business that started doing affiliate marketing. We write a lot of unique content and use a service called Tynt which appends our url with a hash tag to help us retain credit when someone copies or scrapes our content.
  #6  
Old June 26th, 2012, 08:34 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Could you try disabling the Tynt plugin just to see if that is causing the problem? You don't have to disable forever. Just to test.

Eric
  #7  
Old June 27th, 2012, 10:39 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Gary,

WP, Headway, and Google rely heavily on canonicals, so there is no way to turn to them off. Unless I create a subdomain..maybe.

I removed the Tynt code and deactivated the plugins, but I still have part of the homepage http://www.synergybyjasmine.com/ replicated on my store page http://www.synergybyjasmine.com/store/. I don't have any of these pages linked so I have no idea why this is happening.

I have two WP store pages one for http://www.synergybyjasmine.com/estore/ and the other http://www.synergybyjasmine.com/store/. I think I originally had it gong to estore, then I changed it to store.

Getting to the point where i'd rather remove Datafeedr and use product direct linking to our blogposts.
  #8  
Old June 28th, 2012, 07:07 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi
Quote:
Originally Posted by synergybyjasmine View Post
Getting to the point where i'd rather remove Datafeedr and use product direct linking to our blogposts.
Could you explain what you mean? I'm not sure I understand but once I do I can help you set up your site like you want it.

Eric
  #9  
Old June 30th, 2012, 10:46 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Eric,

It seems like my site is blowing up with over 2800 not found 404s on Google Webmaster almost all related to Datafeedr. I thought I had the categories no index, follow with this script in my Head tag;

[store.if page="on"]
<meta name="robots" content="noindex,follow" />'
[/store.if]

I added this script thinking it would help me avoid dupe content issues with so many people using the same product descriptions. Any remaining authorship questions would follow the canonicals back to the site owner (vendor) as I think it should.

Why am I getting so many 404 errors in webmaster tools?

I really liked the way the store was looking two weeks ago. Had our store set-up and looking slightly like Barnes and Noble's site, which made me kinda excited. I had the images cached on my web server to speed up performance and it seemed to work pretty good.

Seems like it all started when...

1. I added code to have a Facebook Like on each product detail page and that's when it seems that everything went to pot. http://www.datafeedr.com/forums/showthread.php?t=7168 I added the HTML script into a box on my Product Details page and have just deleted that box.

2. Noticed that WordPress SEO plugin has been getting a lot of upgrades the past month.

3. I accidentally upgraded to WP 3.4.1, which I usually like staying at least one version behind until bugs are worked out.

Where do I go from here? The Store Front Default page is still mirroring elements from my Home Page. I don't have any pages linked, and no idea why changes in WP Headway Visual Editor to either http://www.synergybyjasmine.com/store/ or http://www.synergybyjasmine.com/estore/ results in changes to the homepage as well.

Thank you,

Michael
  #10  
Old July 1st, 2012, 08:47 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

The only thing I can figure is that Google is counting all "noindex,follow" pages as 404's. Can you try removing that code from the Factory and wait a few days to see if the 404's start disappearing.

There's nothing else that I can think that would be causing this issue.

Eric
  #11  
Old July 15th, 2012, 10:29 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Eric,

I am still having the same issue with the Store Front Default page mirroring elements from my Home Page. I don't have any pages linked, and no idea why changes in WP Headway Visual Editor to either http://www.synergybyjasmine.com/store/ or http://www.synergybyjasmine.com/estore/ results in changes to the homepage as well.

I've been in regular contact with Headyway Tech support and after I've disabled all of my plugins I do not have an issue with the http://www.synergybyjasmine.com/store/ mirroring the Homepage. Headway Tech support said the mirroring or linking issue has something to do with the Datafeedr plugin. I also just asked them about updating the functions.php file for proper canonicalization.

I recently added the Facebook Like function to Datafeedr, using his post below

http://www.datafeedr.com/forums/show...index%2Cfollow

However, this doesn't seem to be working anyway. Could the code for the FB Like have something to do with the mirroring issue. I didn't seem to have this problem before I added that code.

Any other ideas?

Thank you,

Michael
  #12  
Old July 16th, 2012, 06:38 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Try removing the Facebook code to see if that fixes the issue.

Otherwise, try deleting the eStore page from your website. It has no content anyway.

Eric
  #13  
Old July 16th, 2012, 11:35 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Eric,

I deleted the estore WP page, removed the FB code from the Category and Product Description page and head. I also removed a Drop-down widget...

[category.list id='dfparent' before='<ul id="nav">' after='</ul>']
<li>
<a href="[category.link]" title="[category.name]">[category.name]</a>
[category.list id='dfchild' before='<ul>' after='</ul>']
<li>
<a href="[category.link]" title="[category.name]">[category.name]</a>
[category.repeat id='dfchild']
</li>
[/category.list]
</li>
[/category.list]

What is the unordered Category list under the widget section? Here's the code

[category.list id='dfparent' before='<ul id="nav">' after='</ul>']
<li>
<a href="[category.link]" title="[category.name]">[category.name]</a>
[category.list id='dfchild' before='<ul>' after='</ul>']
<li>
<a href="[category.link]" title="[category.name]">[category.name]</a>
[category.repeat id='dfchild']
</li>
[/category.list]
</li>
[/category.list]
  #14  
Old July 17th, 2012, 06:27 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by synergybyjasmine View Post
What is the unordered Category list under the widget section? Here's the code

[category.list id='dfparent' before='<ul id="nav">' after='</ul>']
<li>
<a href="[category.link]" title="[category.name]">[category.name]</a>
[category.list id='dfchild' before='<ul>' after='</ul>']
<li>
<a href="[category.link]" title="[category.name]">[category.name]</a>
[category.repeat id='dfchild']
</li>
[/category.list]
</li>
[/category.list]
That's just a widget that displays a list of categories in your store. It's not a default widget. It must have been added at some point.

It appears deleting the eStore page worked.

Eric
  #15  
Old July 18th, 2012, 10:22 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Eric,

I am still have the same mirroring issue between the homepage and the store page. I really don;t want any of the homepage elements on the store page. I added an "!" mark to the Romantic Birthday Ideas button on my store page (which really shouldn't be there, some how its mirroring the homepage) and it carried over to the home page. My store page shouldn't have any of the elements from Homepage, which I've included in a screenshot attached.

For some reason the store has partially become the homepage. Whenever I try to delete the buttons on elements on the store page, they are also deleted from my Homepage. Headway Tech support is telling me its an issue with Datafeedr. Am I missing something simple int the setup-up of my store?

If not, can I reset to default without loosing all of my categories and products?

Thank you
Attached Thumbnails
Click image for larger version

Name:	Homepage.jpg
Views:	147
Size:	112.7 KB
ID:	483  
  #16  
Old July 19th, 2012, 06:21 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I'm guessing that stuff is there because your "Store" page is using a the same template as the your home page.

Try checking what page template the "About" page is using. Then go to your "Store" page and set the page template to what the "About" page is using. That should remove that block.

Eric
  #17  
Old July 23rd, 2012, 10:55 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Eric,

I think figured it out!! In the Datafeedr Advanced Store Settings, I had entered eStore under the Page Title and Page Slug. When I deleted both fields, I stopped that mirroring of my Homepage. Had a feeling it might have been a simple setting, and nothing too complicated.

For some reason my Visual Editor now lists two Store pages, so should I delete the WP Store page?

Thank you
  #18  
Old July 24th, 2012, 08:29 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Yes, delete the second "Store" page which has a slug that is not "store".

Eric
  #19  
Old July 31st, 2012, 06:23 AM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Eric,

It seems that Google is indexing and following all of my items, which is not good for 404 errors, if the items have been removed during one of the auto or manual product updates.

I just received an SEO Moz report that for the first time shows 250+ 404s related to my Datafeedr store, even though we now have over 3,000 404 errors in webmaster.

Not sure why SEO Moz was so delayed, but I just removed the following script from the Head section of my Category Page view...

[store.if page="on"]
<meta name="robots" content="noindex,nofollow" />'
[/store.if]

I attached what most of the 404s look like and I am wondering if I should have this script installed in the head of my Product Detail views instead?

Is anyone else having this same issue? Maybe I made a customization that is inadvertantly screwing me up?

Is there a way to reset the whole store yet keep the product searches I've saved?

Thank you
Attached Files
File Type: pdf 404_errors.pdf (22.0 KB, 168 views)
  #20  
Old July 31st, 2012, 06:30 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

All but 1 of the URLs in your PDF are category pages. But upon clicking through to some of the URLs, I can see that they are not 404's. I'm not sure if it's related to whatever plugin is adding the #axzz22CNEHvtS to the end of your URLs but it would be worth investigating.

The noindex,nofollow code might be what is responsible for generating the 404 errors. If you don't want search engines going to those URLs, you should put a rel="nofollow" on the links. That might help prevent all of the 404 errors on your site.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
In Product detail page - How to show related accessories like related product sandeep821 Questions 2 April 21st, 2012 11:58 AM
Error When Updating Store stayfitcentral Problems 1 December 9th, 2011 07:43 PM
BIG store error tblogster Problems 1 June 6th, 2011 07:14 PM
error downloading store 1on1im Problems 1 May 24th, 2011 12:20 PM


All times are GMT -5. The time now is 04:35 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.