Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old March 27th, 2014, 07:35 AM
gpsugar1 gpsugar1 is offline
 
Join Date: Nov 2013
Posts: 85
Default "Buy" link not working consistently

Just realized on one of my sites- when I click the "Buy" button on random products, most time sit clicks through to product on merchant's site no problem, but some items are just opening up a magnified image of the product in a new window-

I'll get:

mysite.com/wp-content/uploads/store/products/images/505301726001315.jpg

Doesn't seem to be rhyme or reason to what works and what doesn't.

any idea?
  #2  
Old March 27th, 2014, 07:51 AM
stefan stefan is offline
 
Join Date: Feb 2008
Posts: 5,901
Default

Can you provide a page URL on your site where that happens?

Or an example or two of products with such buy links (product names including merchant name)?
  #3  
Old March 27th, 2014, 08:25 AM
gpsugar1 gpsugar1 is offline
 
Join Date: Nov 2013
Posts: 85
Default

Sure. Please edit post to erase URL once you check it out:

REMOVED

Check "Cherry blossom porcelain tea" on that page

Last edited by stefan : March 27th, 2014 at 09:12 AM.
  #4  
Old March 27th, 2014, 09:12 AM
stefan stefan is offline
 
Join Date: Feb 2008
Posts: 5,901
Default

All your buy links refer to an image. They all have .jpg extension.

That's because you use %li for the buy link in Store > URL Settings.

If you host your images locally you should change the Product image field to %li not the buy link.

To fix the problem:

- Go to Store > URL Settings

- Replace in buy link field %li by store/product/buy/%pi/%ps/

- Change the Product image field to %li

- Save. Then click the "Products and Settings" button in plugin.

Last edited by stefan : March 27th, 2014 at 09:13 AM.
  #5  
Old March 27th, 2014, 12:00 PM
gpsugar1 gpsugar1 is offline
 
Join Date: Nov 2013
Posts: 85
Default

Oh so I mixed them up I guess?

For hosting images locally, should be (product thumbnail) %li first and THEN (buy link) %lt right?
  #6  
Old March 27th, 2014, 12:35 PM
stefan stefan is offline
 
Join Date: Feb 2008
Posts: 5,901
Default

Quote:
Originally Posted by gpsugar1 View Post
For hosting images locally, should be (product thumbnail) %li first and THEN (buy link) %lt right?
The buy link URL field should never contain %li or %lt. Otherwise the buy link will point to an image URL.

Follow the instructions as explained in my previous post to fix the problem.

Or apply the same URL settings of another store in your account which hosts the images locally.
  #7  
Old March 27th, 2014, 01:05 PM
gpsugar1 gpsugar1 is offline
 
Join Date: Nov 2013
Posts: 85
Default

Oh ok- I see what I did. Ugh.....thanks man.
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Product links to "Invalid Affiliate Link" through AvantLink outdoorcampingshops Problems 2 February 19th, 2013 08:10 PM
"Invalid Link" message after clicking the product detail page myefashion Questions 2 February 15th, 2013 12:42 AM
Change "Home" link in breadcrumb on Search Page bolshoes Questions 2 September 4th, 2012 07:59 PM
"See all sale items" link is not working cashnow1 Questions 0 October 27th, 2011 07:04 PM
The Forum: "View Active Topics" link? jackrock Questions 2 October 27th, 2011 06:17 PM


All times are GMT -5. The time now is 12:30 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.