Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 20th, 2011, 04:43 PM
k9marketing k9marketing is offline
 
Join Date: Nov 2010
Posts: 33
Default Fatal Error Message

My site had site. www.k9marketing.com had no posts (published or scheduled) for about 16 hours which is longer than it had in the past. I tried to do a manual drip from the plugin menu and received an error. Not I get an error when I open the site.

Warning: mysql_fetch_object(): supplied argument is not a valid MySQL result resource in /homepages/19/d146332263/htdocs/k9/wp-content/plugins/datafeedr/datafeedr.php on line 409

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /homepages/19/d146332263/htdocs/k9/wp-content/plugins/datafeedr/datafeedr.php on line 411

This is showing up in the sidebar. No post or menus are showing up either. Any thoughts?
  #2  
Old January 20th, 2011, 04:45 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Are you using Version 1 or Version 3 because you have posted in the Version 1 section?
  #3  
Old January 20th, 2011, 04:46 PM
k9marketing k9marketing is offline
 
Join Date: Nov 2010
Posts: 33
Default

version 3. I will move it over to the other forum
  #4  
Old January 20th, 2011, 04:48 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Thread moved.
  #5  
Old January 20th, 2011, 04:48 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

What version of the Datafeedr plugin are you using? You can check that at the bottom of this page: WordPress Admin Area > Tools > Datafeedr
  #6  
Old January 20th, 2011, 04:49 PM
k9marketing k9marketing is offline
 
Join Date: Nov 2010
Posts: 33
Default

3.02.2946
  #7  
Old January 20th, 2011, 04:51 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Try going to WordPress Admin Area > Tools > Datafeedr > Debug and clicking the [Rsest] button underneath the "Updates" area. Then click the [Update Products and Settings] button again.
  #8  
Old January 20th, 2011, 04:55 PM
k9marketing k9marketing is offline
 
Join Date: Nov 2010
Posts: 33
Default

tried it. did not solve the problem
  #9  
Old January 20th, 2011, 05:09 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Can you PM me the following information:

FTP LOGIN INFORMATION (Temporary login information preferred)
Host:
Login:
Password:

BLOG LOGIN INFO with ADMINISTRATOR PERMISSIONS (Temporary login information preferred)
Admin URL:
Username:
Password:

Thanks,
Eric
  #10  
Old January 21st, 2011, 08:34 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

The reason for the errors is one complex query in the drip section of the plugin which results in MySQL running out of memory. Increasing the memory limit in php didn't work. We're looking for ways to simplify the query.

In the meantime, we've disabled the drip for your store to get your site back up and working.

I will update once the memory issue has been addressed.

Eric
  #11  
Old January 21st, 2011, 12:17 PM
k9marketing k9marketing is offline
 
Join Date: Nov 2010
Posts: 33
Default

Thanks.

FYI: Here is some info that I received from my hosting company (1 and 1) a couple of weeks back when I was having trouble updating WP. Didn't work, I still could not use the automated update...

Quote:
The issue that you are having is inregards with the PHP memory limit, you can increase that by creating a php.ini file, then insert this code on your file :

memory_limit = 30M
allow_url_fopen = on
max_file_uploads = 100000
upload_max_filesize = 100M
post_max_size = 20M

Note : You will need to upload the php.ini file on the directory where your domain name is pointed to. Then you may now update your wordpress version. You can also deactivate one of your plugin, then update your wordpress version.
  #12  
Old January 21st, 2011, 01:00 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Thanks for the additional information.
  #13  
Old January 22nd, 2011, 10:03 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

OK, I think we figured out what's going on. The query which retrieved the posts to drip had a problem in it. This has been fixed on your site and your site is dripping products again.

Eric
  #14  
Old January 22nd, 2011, 02:34 PM
k9marketing k9marketing is offline
 
Join Date: Nov 2010
Posts: 33
Default

Thanks. I appreciate the quick turnaround on the issue.
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fatal error message gardenpublishing Problems 2 January 20th, 2011 02:43 PM


All times are GMT -5. The time now is 11:52 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.