Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 16th, 2015, 11:34 AM
burlyqlady burlyqlady is offline
 
Join Date: Dec 2013
Posts: 20
Default Drip posts show shortcode only

Hi. I just set up a simple drip template and products have started dripping to my site. Unfortunately, the post only shows the single shortcode [DFR:drip?p=777700003317891] in the content section (with differing ID numbers).

I've cleared my browser cache and made sure that my theme calls the_content()

What else can I do?
  #2  
Old January 16th, 2015, 11:50 AM
burlyqlady burlyqlady is offline
 
Join Date: Dec 2013
Posts: 20
Default

Oops I meant to write that I have the cache setting off.
  #3  
Old January 16th, 2015, 06:20 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Hmmm... that doesn't sound right.

What file did you check to find the the_content() function in?

Also, can you post URL to page in question?

Eric
  #4  
Old January 16th, 2015, 06:31 PM
burlyqlady burlyqlady is offline
 
Join Date: Dec 2013
Posts: 20
Default

I checked my theme files. I'm pretty sure the single post php file calls the_content.

I just reset the dripfeed, so here's a fresh post: http://www.skincaredupes.com/ingredi...am-1-8-ounces/

I see a blank and in the edit post content box I see this: [DFR:drip?p=777700000133651] instead of the product description that (I think?) should be there?
  #5  
Old January 17th, 2015, 11:27 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Try editing your post and add the word "Test" before the shortcode [DFR:drip?p=777700000133651].

So your post will look like this:

Quote:
Test [DFR:drip?p=777700000133651]
Save and then view on your site. See if that changes anything.

Eric
  #6  
Old January 17th, 2015, 03:57 PM
burlyqlady burlyqlady is offline
 
Join Date: Dec 2013
Posts: 20
Default

Hi Eric,

all I see now is the word Test.
  #7  
Old January 18th, 2015, 10:07 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Can you send a copy of your theme to help@datafeedr.com so that I can test your theme?

Thanks,
Eric
  #8  
Old January 19th, 2015, 10:27 AM
burlyqlady burlyqlady is offline
 
Join Date: Dec 2013
Posts: 20
Default

Sure, I'll do that now.
  #9  
Old January 19th, 2015, 10:41 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Thanks! I installed your theme into my test site and my dripped posts are displaying just fine.



Do you have any plugins installed which might be manipulating shortcodes?

Eric
  #10  
Old January 19th, 2015, 10:51 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

I found the issue. You had a missing ending PHP tag in your Drip Template.

You also have a [product.each] and [product.end] tag in your Product detail view. Those were also causing problems.

Here's what you had:

HTML Code:
<div class="sp">
  <div class="lc">
    <div class="thmb">
      <a href="[product.url]" title="[product.name]" target="_blank" rel="nofollow">
        [product.image tag='1']
      </a>
    </div>
  </div>
  <div class="rc">
    <h2><a href="[product.url]" title="[product.name]" target="_blank" rel="nofollow">[product.name]</a></h2>
    <p class="desc">[product.description html='yes']</p>
    <div class="prc">[product.currency mode='sign'][product.price]</div>
    <?php if ($product->saleprice > 0 &&  $product->saleprice < $product->price) { ?>
  <div class="prc">
    <small>
      Was: <span style="text-decoration: line-through;">[product.currency mode='sign'][product.price]</span>
      Now: <span style="font-weight: bold; color:red;">[product.currency mode='sign'][product.saleprice]</span>
    </small>
  </div>
<?php } else { ?>
  <div class="prc">
    <small>
      [product.currency mode='sign'][product.price]
    </small>
  </div>    
[product.each]
  <p>
    <a href="[product.link]"><strong>[product.name]</strong></a> from <span style="color:#999;font-size:85%;font-style:italic;">[product.merchant]</span><br />
    [coupon.description]<br />
    <small>
      <?php if ($$[coupon.code]!='') : ?><strong>Coupon promo code:</strong> [coupon.code]<br /><?php endif; ?>
      <?php if ($$[coupon.begin]!='') : ?><strong>Begin Date:</strong> [coupon.begin]<br /><?php endif; ?>
      <?php if ($$[coupon.end]!='') : ?><strong>End Date:</strong> [coupon.end]<br /><?php endif; ?>
      <?php if ($$[coupon.restrictions]!='') : ?><strong>Restrictions:</strong> [coupon.restrictions]<br /><?php endif; ?>
    </small>
  </p>
[product.end]
    <div class="btns">
      <a href="[product.url]" class="dfbutton dforange dflarge" title="Buy this product" rel="nofollow">Buy</a>
    </div>
  </div>
  <div class="clearingdiv"> </div>
</div> 
<div class="clearingdiv">&nbsp;</div>
[ebay_show_items keywords="[product.name]" category_id="11863"]
<div class="clearingdiv">&nbsp;</div>
Here's what I changed it to:

HTML Code:
<div class="sp">
  <div class="lc">
    <div class="thmb">
      <a href="[product.url]" title="[product.name]" target="_blank" rel="nofollow">
        [product.image tag='1']
      </a>
    </div>
  </div>
  <div class="rc">
    <h2><a href="[product.url]" title="[product.name]" target="_blank" rel="nofollow">[product.name]</a></h2>
    <p class="desc">[product.description html='yes']</p>
    <div class="prc">[product.currency mode='sign'][product.price]</div>
    <?php if ($product->saleprice > 0 &&  $product->saleprice < $product->price) { ?>
  <div class="prc">
    <small>
      Was: <span style="text-decoration: line-through;">[product.currency mode='sign'][product.price]</span>
      Now: <span style="font-weight: bold; color:red;">[product.currency mode='sign'][product.saleprice]</span>
    </small>
  </div>
<?php } else { ?>
  <div class="prc">
    <small>
      [product.currency mode='sign'][product.price]
    </small>
  </div>
  <?php } ?>
    <div class="btns">
      <a href="[product.url]" class="dfbutton dforange dflarge" title="Buy this product" rel="nofollow">Buy</a>
    </div>
  </div>
  <div class="clearingdiv"> </div>
</div> 
<div class="clearingdiv">&nbsp;</div>
[ebay_show_items keywords="[product.name]" category_id="11863"]
<div class="clearingdiv">&nbsp;</div>
Now everything works as it should.

To fix it on your site, go here WordPress Admin Area > Tools > Datafeedr and click the [Update Settings Only] button.

Eric
  #11  
Old January 25th, 2015, 10:12 AM
burlyqlady burlyqlady is offline
 
Join Date: Dec 2013
Posts: 20
Default

Oh my gosh, thank you so much!!! I'm gonna go check it now if it worked
  #12  
Old January 25th, 2015, 10:15 AM
burlyqlady burlyqlady is offline
 
Join Date: Dec 2013
Posts: 20
Default

Okay, it's definitely worked, thank you SO MUCH.Quick question: is there any way to import the live text and images into my posts? Instead of just the shortcode?
  #13  
Old January 25th, 2015, 10:37 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Glad it worked. Unfortunately importing the text into your post is not possible. For images, try this: http://www.datafeedr.com/forums/show...8265#post38265

Eric
  #14  
Old January 25th, 2015, 10:46 AM
burlyqlady burlyqlady is offline
 
Join Date: Dec 2013
Posts: 20
Default

okay, do you think it'll be possible in the future? because that would be amazing!
  #15  
Old January 25th, 2015, 10:49 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

We don't have plans for that.
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to show products in posts via tags? brinch Tips, Tricks & Tutorials 2 July 18th, 2014 09:33 AM
How to show products in posts via tags? brinch Tips, Tricks & Tutorials 1 July 18th, 2014 09:21 AM
Products don't show in WP posts scgllc Questions 2 March 25th, 2013 02:49 PM


All times are GMT -5. The time now is 06:34 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.