Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old February 24th, 2012, 07:53 PM
firstprod firstprod is offline
 
Join Date: Jul 2009
Posts: 71
Default Saving images on local server does not work if they have the extension ".jpeg"

I was writing a PHP image processor to generate cropped thumbnails from the saved DFR full sized images for a test design, and I've just noticed that the functionality to save images to the local server, under "product URLs" with the help as follows:

"Path for a product's image.

RECOMMENDED: Include the product's ID placeholder in this field so there is no conflict between products with the same name.

Example Settings:
store/image/%pi/
store/images/%ps/%pi/
store/images/%pi.%pe
%li"

Doesn't work if the image in question being served by the merchant has the extension ".jpeg" (as opposed to ".jpg" which works fine). I think that there must be some sort of exception or omission in the script for this notation of the extension.

As it stands the script is reloading the images every time from the merchant server and not saving them onto the local server, which is slowing up the site performance considerably for me.
  #2  
Old February 24th, 2012, 08:10 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Can you provide a product ID and URL of the image with the extension .jpeg?

Thanks,
Eric
  #3  
Old February 24th, 2012, 08:22 PM
firstprod firstprod is offline
 
Join Date: Jul 2009
Posts: 71
Default

Sure, product ID 416200196631147 "Stompa Uno Cabin Bed 1a inc. Desk and Cube Unit"
The affiliate image URL listed in the Factory is http://www.time4sleep.co.uk/media/ca...kclosed_2.jpeg

The DFR URL version of the image does not save onto the server, although other images from the same merchant ending .jpg save on the local server without problems. I also tried loading the image URL above direct into my own image processor and it was fine.

Ty
  #4  
Old February 25th, 2012, 08:20 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

We're still looking into this.
  #5  
Old February 26th, 2012, 06:56 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

This issue has been fixed in version 3.6 which will be released soon.

Eric
  #6  
Old March 14th, 2012, 12:55 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

This issue is fixed in version 3.6.

Eric
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Instructions to Remove the word "Store" don't work jdrom Problems 1 August 9th, 2011 08:09 AM
2 "browse by" forms don't work SaSh Problems 3 April 13th, 2011 08:41 AM


All times are GMT -5. The time now is 09:59 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.