Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Problems
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 19th, 2011, 03:45 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default When I click my Buy link, I'm redirected back to my homepage, not the merchant's site

If you click the "Buy" link on your site and you are redirected back to your store's front page or your website's homepage, it could be due to a number of reasons.

Here are links where others were having the same problems and how they were resolved:

Conflict with the Yoast WordPress SEO plugin - http://www.datafeedr.com/forums/showthread.php?t=3597
Conflict with the LinkHopper plugin - http://www.datafeedr.com/forums/showthread.php?t=3710

If more conflicts are found, this post will be updated.

Eric
  #2  
Old January 22nd, 2011, 01:02 AM
lanarkchiro lanarkchiro is offline
 
Join Date: Sep 2010
Posts: 49
Default still having issues

i apologize is this is a duplicate, i cant find my other post. I do not have the above plugins. i tried deactivating others i have just in case, but it made no difference. when i click on posts, there are no images and the page just refreshes. There is no redirect anywhere.
http://coffeebeanky.com

It never happened the first few stores i updated, now it is on the last 2 stores i updated
  #3  
Old January 22nd, 2011, 01:04 AM
lanarkchiro lanarkchiro is offline
 
Join Date: Sep 2010
Posts: 49
Default just a little more clarification

All the new posts after updated store, does redirect. Only the old posts and products willl not
  #4  
Old January 22nd, 2011, 09:32 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by lanarkchiro View Post
All the new posts after updated store, does redirect. Only the old posts and products willl not
Are those dripped posts? If so, that's because the new plugin does not support previously dripped posts, as mentioned in the "Before you Upgrade" section here: http://www.datafeedr.com/docs/item/166

I've created a quick patch here if you need to have previously dripped posts working: http://www.datafeedr.com/forums/showthread.php?t=3530

Eric
  #5  
Old January 22nd, 2011, 01:20 PM
lanarkchiro lanarkchiro is offline
 
Join Date: Sep 2010
Posts: 49
Default thanks so much

I guess i have to do a better job reading
thanks
shawni
  #6  
Old July 5th, 2011, 07:56 PM
schemjo schemjo is offline
 
Join Date: Jun 2011
Posts: 14
Default

I'm having the same issue but I do not have those plugins. The only extra plugins I have are Display Widgets and Exclude Pages from Navigation but I've had these since beginning working on the store and it was working.

Any assistance would be greatly appreciated.

Thanks!
Joe
  #7  
Old July 5th, 2011, 08:16 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Make sure you have entered in the correct affiliate IDs for each network.

Make sure that after you have entered in the correct affiliate IDs that you click [Update Products and Settings] to update your store.

Also make sure you are approved by each merchant you are promoting.

Eric
  #8  
Old July 5th, 2011, 08:26 PM
schemjo schemjo is offline
 
Join Date: Jun 2011
Posts: 14
Default

Hey Eric - I did change Google affiliate ID's but I verified the new ID is correct. Would this matter that I started out with one ID then switched?

Thanks,
Joe
  #9  
Old July 5th, 2011, 09:02 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Did you already click the [Update Products and Settings] button?

Eric
  #10  
Old July 8th, 2011, 09:49 PM
schemjo schemjo is offline
 
Join Date: Jun 2011
Posts: 14
Default

Hey Eric - I did click the Update products and settings several times and deleted the cache. I did have a custom URL setup (instead of /store I used something else). After resetting back to the default structure it's working again but the weird thing is was working w/ the other structure. For the time being I'll just leave it w/ the default settings.

Thanks,
Joe
  #11  
Old July 8th, 2011, 11:33 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

Sounds like your URL settings had a conflict in them causing the bad redirect.

Eric
  #12  
Old November 23rd, 2011, 06:02 AM
webnamescouk webnamescouk is offline
 
Join Date: Nov 2011
Posts: 65
Default

I'm getting the same issue - http://www.blackhighheelshoes.co.uk/
Products clicked on the homepage always redirect to the homepage URL, never the actual store.
I'm guessing this is a problem with the setup, the store is on the frontpage so i just removed the /store URL!
Any ideas?

This is with the SEO plugin by Yoast disabled as well, so it would seem to be an issue when you have the storefront on the homepage?

Last edited by webnamescouk : November 23rd, 2011 at 06:04 AM.
  #13  
Old November 23rd, 2011, 08:22 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

This is what happens with Affiliate Window if merchants if:

1. Your affiliate ID is incorrect

2. Or you have not been approved by the merchant

You should check both of those things.

Eric
  #14  
Old October 7th, 2012, 07:15 AM
toniologe toniologe is offline
 
Join Date: Aug 2011
Posts: 211
Default

Hi on Tradetracker, if u use it u can set up a URL to reconnect if some of the products have fails or else.. Perhaps thats it . Look at the side at tradetracker.
cu Toni Please feel free to visit www.reisebuero-tuttlingen.de . There you can see the same if a product gets failed . cu Toni
__________________
My private side: http://www.toni-schlack.de
my project: http://www.dp10.de
Skype: Toniologe Sip: Germany 07721-9461045
my preferred language(s): german, english
  #15  
Old July 12th, 2013, 11:25 AM
evyral evyral is offline
 
Join Date: Jul 2013
Posts: 1
Default

Hi
I am having this same problem but when I hit the "buy now" it opens this new url: http://www.pepperjamnetwork.com/tracking/error.php
I am sure I entered the pepperjam affiliate id correctly...
I'm not sure how to fix this.

Thanks
  #16  
Old July 12th, 2013, 11:33 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

I don't see your Pepperjam affiliate ID entered at all:



Eric
  #17  
Old February 19th, 2014, 01:50 PM
scarper47 scarper47 is offline
 
Join Date: Jan 2014
Posts: 1
Default Buy Button Going Back To Homepage

Store ID: 44483
Website URL: 360airbeds.com
URL to page in question:

OK. Here is what is happening. As a new novice around these parts this has left me scratching my head.
To keep it very simple I have a uploaded a brand new Wordpress blog with no other plugins.
I have added the Datafeedr plugin. Added the connection key and updated etc.
I have done nothing else at all. However when I click on a buy button on any of the products in my store it simply opens a new window which heads back to my home page.
I hope someone can help out there. It could be something glaringly obvious but, hey, that's how we all learn. Many thanks.
  #18  
Old February 19th, 2014, 01:54 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

Welcome to the forums!

I see that your products are from Affiliate Window Network. This is what happens when either:

1. Your Affiliate Window Affiliate ID is incorrect. Please make sure you have the correct AW affiliate ID: http://www.datafeedr.com/docs/item/101

2. You are not approved by the merchants whom you're displaying products from. Make sure that you have been approved by all of the Affiliate Window merchants you have selected to use in your store.

Eric

Last edited by stefan : February 19th, 2014 at 02:20 PM.
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:18 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.