Datafeedr Support Forums  

Go Back   Datafeedr Support Forums > Current Version (V3) Forum > Tips, Tricks & Tutorials
Home Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Important - The support forums are now in "read-only" mode as we transition to an alternative help desk solution. Feel free to contact us here with any of your questions or search the forums for an existing solution.
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old April 30th, 2012, 08:53 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default What to do when product images cannot be saved locally or their URL masked

Sometimes merchants impose access controls on their images so that we cannot download them and store them locally nor can we rewrite the image URL. The only way to get the image to display on your website is by requesting the image directly from the merchant's server.

Here's how to change your site so that you are pulling images directly from the merchants' servers:

1. Go here: The Factory > Your Store > VIEWS > STORE FRONT PAGE > Default

2. Click the theme icon ( ) for the Product list module.

3. Change [product.thumbnail tag='1'] to [product.thumbnail tag='1' direct='1']

4. Click the [Save changes] button.

5. Repeat steps 2~4 for the following views:
  • The Factory > Your Store > VIEWS > CATEGORY PAGE > Default
  • The Factory > Your Store > VIEWS > SEARCH PAGE > Default
  • The Factory > Your Store > VIEWS > PRODUCTS BY TAG > Default
  • The Factory > Your Store > VIEWS > WIDGETS > Products > Default
  • The Factory > Your Store > VIEWS > CUSTOM VIEWS > Related Products > Default
  • The Factory > Your Store > VIEWS > CUSTOM VIEWS > Sale Items > Default

6. Go here: The Factory > Your Store > VIEWS > PRODUCT DETAIL > Default

7. Click the theme icon ( ) for the Product detail module.

8. Change [product.image tag='1'] to [product.image tag='1' direct='1']

9. Click the [Save changes] button.

10. Go here: The Factory > Your Store > VIEWS > DRIP TEMPLATE > Default

11. Click the theme icon ( ) for the Product detail module.

12. Change [product.image] to [product.image direct='1']

13. Click the [Save changes] button.

14. Go here: WordPress Admin Area > Tools > Datafeedr

15. Click the [Update Settings Only] button.

That should do it.

Eric
  #2  
Old April 30th, 2012, 10:28 AM
1800HART 1800HART is offline
 
Join Date: Apr 2008
Posts: 487
Default

for those of us caching/storing images on our own domain ... do you recommend that we update our stores this way to request the image directly from the merchant's server by default? or, only if there is a problem?
__________________
| Shop @ HART Markets | Twitter |
  #3  
Old April 30th, 2012, 10:34 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi
Quote:
Originally Posted by 1800HART View Post
for those of us caching/storing images on our own domain ... do you recommend that we update our stores this way to request the image directly from the merchant's server by default? or, only if there is a problem?
Good question! Only do this if there is a problem. There is NO reason to take these steps if your product images are loading fine.

Eric
  #4  
Old May 1st, 2012, 02:31 AM
madsem madsem is offline
 
Join Date: Apr 2012
Posts: 10
Default

Ok, I made a plugin for that. It masks all image urls and always delivers nice permalinks no matter if the merchant limits access or not I'll make a new thread and share it with you guys.
  #5  
Old July 30th, 2012, 08:17 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Hi Eric,

Thank you, I made those changes since 2 of my most linked to merchants Gaiam and Yoga Accessories have had this issue a few times.

I already had the Directories tab all set-up to cache these images locally, (merchant logo, CSS Dir, Product images, Product thumbs, Backup, and Temp Dir). Should I still keep the local caches? If not what's the best way to remove them.

Thank you,

Michael
  #6  
Old July 31st, 2012, 06:09 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi

You can get rid of Product images and Product thumbs. Just delete the fields and click the Save button.

Eric
  #7  
Old August 1st, 2012, 09:31 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

Thank you
  #8  
Old August 2nd, 2012, 10:46 PM
synergybyjasmine synergybyjasmine is offline
 
Join Date: Apr 2012
Posts: 44
Default

HELP!!!

When I made these changes on 7/30 everything looked good. I followed the steps word for word, and updated my products and settings.

Tonight, browsing through my store when I click on any of my items I get a blank page, no image nor descriptions. If I click on the Buy button it takes me to the publisher page to buy. What's going on?

PLEASE HELP!

Why am i having such a hard time using this software?? This is beyond frustrating!!! Can I just give someone a wireframe of how I want my store to look, then I'll just manage what products I want to carry and have someone manage the back-end of this plugin??

1. 10,000+ Canonicals notices. I've tried a ton of different things to fix my canonicals, still getting over 10,000 canonical notices through SEO Moz.
http://www.datafeedr.com/forums/show...highlight=1100

2. I now have over 3400 not found 404 errors in webmaster
http://www.datafeedr.com/forums/showthread.php?t=7177

I really need some answers and hopefully someone can help!

Last edited by synergybyjasmine : August 2nd, 2012 at 10:56 PM. Reason: More feedback
  #9  
Old August 3rd, 2012, 04:14 AM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by synergybyjasmine View Post
HELP!!!

When I made these changes on 7/30 everything looked good. I followed the steps word for word, and updated my products and settings.

Tonight, browsing through my store when I click on any of my items I get a blank page, no image nor descriptions. If I click on the Buy button it takes me to the publisher page to buy. What's going on?

PLEASE HELP!
Hi

The reason your products pages are not appearing has nothing to do with these changes. It's because you have a random ending tag in your Product details <head> elements.



You need to remove [/store.if] from your <head> elements here: The Factory > Your Store > VIEWS > PRODUCT DETAILS > Default > View menu > View <head> Elements.

Eric
  #10  
Old May 10th, 2014, 01:39 PM
vhekler vhekler is offline
 
Join Date: Feb 2014
Posts: 23
Default

Store ID: 44535
URL to page in question: Name of stored images

Hi Eric,

is it possible to store the images, we get from the merchants over Datafeedr with another Name of the File, e.g. artdesignportal_(Number).jpg? The advantage would be, if user download the picture, they know, where they found the image in the web.

regards

Marvin
  #11  
Old May 10th, 2014, 08:23 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Hi,

This is not possible.

Eric
  #12  
Old January 9th, 2015, 09:54 AM
zed7 zed7 is offline
 
Join Date: Mar 2013
Posts: 24
Default

Quote:
Originally Posted by vhekler View Post
Store ID: 44535
URL to page in question: Name of stored images

Hi Eric,

is it possible to store the images, we get from the merchants over Datafeedr with another Name of the File, e.g. artdesignportal_(Number).jpg? The advantage would be, if user download the picture, they know, where they found the image in the web.

regards

Marvin
You could do it by adding artdesignportal_ in front of product.image in your views, and then instruct your webserver i.e. Apache to replace it with regexp. Something like this should work (untested):
RewriteRule ^/(artdesignportal_)([0-9].*\.jpg)$ $2 [L]

Docs: http://httpd.apache.org/docs/2.0/mod...ml#RewriteRule
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hosting Images Locally. billy_w Questions 1 April 3rd, 2012 01:44 PM
Merchants Images Locally macfink Questions 1 July 13th, 2011 02:54 PM
Locally hosted images and thumbnails not showing up elecpulp Problems 4 April 4th, 2011 03:21 PM


All times are GMT -5. The time now is 12:15 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.