View Single Post
  #27  
Old June 21st, 2012, 06:30 PM
Eric's Avatar
Eric Eric is offline
Datafeedr Team
 
Join Date: Feb 2008
Posts: 16,902
Default

Quote:
Originally Posted by andrewjg View Post
1. Any idea why there is such a big gap between the Like button and the breadcrumb trail?

http://store.cheap-computing.com/sto...7801471608370/
Quote:
Originally Posted by nzcid View Post
I have been meaning to ask the same thing about that Gap between the like button and the beginning of the products.
Alternatively, you can put this code in your <head>:
HTML Code:
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
And this code in your Text module:
HTML Code:
<div class="fb-like" data-href="<?php echo datafeedr_tools()->current_url(true); ?>" data-send="true" data-width="450" data-show-faces="true" data-font="arial"></div>
This appears to remove the padding and add additional functionality.

You can use the generator here: http://developers.facebook.com/docs/.../plugins/like/ under "Step 1 - Get Like Button Code". Just make sure to set the data-href to "<?php echo datafeedr_tools()->current_url(true); ?>"

Quote:
Originally Posted by andrewjg View Post
2. I implemented the "category" Facebook Like button and, curiously, it has changed the background colour of the site to black (but it's blue under everything else such as the "product" view): http://store.cheap-computing.com/sto...egory/desktops.
You are missing a double quote in your <head> section:



Quote:
Originally Posted by nzcid View Post
The button shows in all categories so it is not just that one. Image is hosted on my server.
One of my tests worked. I'm guessing you have tested this in a few different categories either before you added the <meta> tag to your <head> or before a category image was added. Unfortunately, Facebook caches things like crazy. So, I believe that it's storing some old image information from your previous tests. I did get it to work with one of your categories and that's what makes me think that it is working correctly but you tested it when it wasn't set up properly and those results have been cached.

Eric