Datafeedr Support Forums

Datafeedr Support Forums (http://www.datafeedr.com/forums/index.php)
-   Tips, Tricks & Tutorials (http://www.datafeedr.com/forums/forumdisplay.php?f=66)
-   -   Make your store's front page the homepage of your website. (http://www.datafeedr.com/forums/showthread.php?t=3604)

Eric January 12th, 2011 01:30 PM

Make your store's front page the homepage of your website.
 
If you want to put your store's front page on the homepage of your site, follow these instructions:
  1. Log into the Factory
  2. Go to your store
  3. Go the the Store menu
  4. Click URL Settings
  5. Delete any words in the "Front page URL" field.
  6. Save your URL Settings
  7. Update your store

Eric

jamesdhayward January 19th, 2011 04:24 PM

The above worked fine - except for my sidebar widgets dropped off? Any hints anyone to get my category list back?

Eric January 19th, 2011 04:25 PM

Sounds like your theme has a different template for the homepage of your website than the rest of your site. But it's hard to say without knowing your site's URL... :rolleyes:

alistair February 21st, 2011 06:44 PM

This happened to me also and when I checked my reading settings my static front page wasn't set as anything so I just set it to the right page and they re-appeared.

dealme April 4th, 2011 02:26 AM

Hi guys,

this worked for me. However I have two headings now 'Home' and 'Store'

when both are clicked they remain on the root domain. I tried deleting the Store page however it didn't like that as nothing showed after that.

How do I remove the Home?

thanks

dealme April 4th, 2011 02:38 AM

Managed to work out how to get rid of the 'store' one - I just set the store one as the static front page and now all I have is the 'Home' heading.

so i guess now I've got to work out how to change the wording of the Home title

dealme April 4th, 2011 06:37 AM

ok so one thing to note don't play around with the functions.php file without keeping a copy of the first - I did and had to reinstall my blog. yay fun.

anywho found this post that worked.


http://en.forums.wordpress.com/topic/how-to-change-home-link-from-menu

nzcid December 26th, 2011 11:52 PM

Quote:

Originally Posted by dealme (Post 19619)
Managed to work out how to get rid of the 'store' one - I just set the store one as the static front page and now all I have is the 'Home' heading.

so i guess now I've got to work out how to change the wording of the Home title


Tried setting my theme as the store one as the static front page, but still have two tabs.

Anyone get this to work so only one tab appears, home tab???

Eric December 27th, 2011 12:00 AM

Hi

I covered this in the video below:
http://www.datafeedr.com/videos?vide...rc=yt#videotop

Eric

nzcid December 27th, 2011 03:20 PM

Quote:

Originally Posted by Eric (Post 27302)
Hi

I covered this in the video below:
http://www.datafeedr.com/videos?vide...rc=yt#videotop

Eric

Hey Eric

This did not work for me, sorry, still have two tabs. Maybe just the theme and speaking of this I am looking for a proffessional looking theme I can use in conjunction with your plug-in.

Any suggestions (surprised you don't sell some yourself)

nzcid December 27th, 2011 04:23 PM

Was the theme but really looking for a proffessional theme to suit what we are trying to do here. Found a theme that allowed custom menus and now only the home button appears.

Happy to get suggestions for really nice looking proffessional themes.

Eric December 27th, 2011 07:49 PM

Quote:

Originally Posted by nzcid (Post 27310)
Was the theme but really looking for a proffessional theme to suit what we are trying to do here. Found a theme that allowed custom menus and now only the home button appears.

Happy to get suggestions for really nice looking proffessional themes.

There are just soooo many themes that it's really hard to suggest.

markz January 6th, 2012 12:07 AM

Hi All:
When I do this, I also get 'home' and 'store' pointing to the same page and both appearing on my navbar (custom menu) ... but this should be easy to fix via menu options.

But what's a major problem is that my theme settings change completely! I lose background color, custom menu navbar settings, 3 cols to 2 cols, etc.
I'm using Suffusion, and don't know where to look to see where the conflict is. (and all pages are set to use default page types, so the home page is not set differently than other pages. and the theme issues appear on all pages).


If I use 'store' as my front page display in WP Reading settings, the theme issues are okay, but nothing is displayed as a store home or front page. (categories still seem to work).

I would like to have the store home page as my front page ...
any solutions?

Thanks!
MarkZ

Eric January 6th, 2012 09:20 AM

Hi

Did you follow the steps outlined in this video:
http://www.datafeedr.com/videos?vide...rc=yt#videotop

Eric

markz January 6th, 2012 10:35 AM

Hi Eric:
Yes, that's the video I was following, to get the store home page to display on the front page of my blogsite. I didn't get so far along to remove the redundant 'home' & 'store' pages from menu navbar ... I'll try that now, and report back*. It's just weird that removing 'store' from the factory url setting blows the whole theme settings.

*yep, as I thought, the redundant pages in navbar menu don't impact that broken theme settings.

Any thoughts?

Thanks,
Markz

Eric January 6th, 2012 02:22 PM

Can you make it so that the problem appears again? It's hard to debug when everything is working.

markz January 6th, 2012 02:56 PM

Hi Eric:
Take a look now: I deleted 'store' from datafeedr factory url setting so the site should be 'incorrect'

markz

Eric January 6th, 2012 03:11 PM

Hi

Can you PM me the following information:

BLOG LOGIN INFO with ADMINISTRATOR PERMISSIONS (Temporary login information preferred)
Admin URL:
Username:
Password:

Thanks,
Eric

markz January 6th, 2012 03:23 PM

PM on its way to you ... let me know if you don't receive it

thanks,
markz

Eric January 6th, 2012 04:49 PM

Hi

OK, there was a conflict between the URL for the CSS file of Suffusion and the CSS file for Datafeedr.

To solve this, I went here: WordPress Admin Area > Appearance > Suffusion Options > Back-end > Site Optimization and chose "Auto-generate the CSS and print it in the HTML source" under the "Auto-generate CSS file for customization options" area.

That fixed the issue.

Eric


All times are GMT -5. The time now is 01:25 AM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.