Datafeedr Support Forums

Datafeedr Support Forums (http://www.datafeedr.com/forums/index.php)
-   Problems (http://www.datafeedr.com/forums/forumdisplay.php?f=68)
-   -   Meta Description & Meta Title not populating on Detail Page (http://www.datafeedr.com/forums/showthread.php?t=10475)

bradleyhebdon April 10th, 2014 01:32 AM

Meta Description & Meta Title not populating on Detail Page
 
I've followed instructions on previous threads to disable Yoast SEO by adding the code to my functions.php file. The meta description and title are populating on my category pages, but not on my detail page.

Any ideas? Thanks.

Detail:
http://www.vintageshopper.com/store/...7300195446185/

Category:
http://www.vintageshopper.com/store/category/wedding/

bradleyhebdon April 10th, 2014 01:48 AM

Looks like it's not working on the category page either...

http://www.vintageshopper.com/store/...dding-dresses/

stefan April 10th, 2014 05:24 AM

2 Attachment(s)
I don't see anything wrong.

I do see the right titles and meta data in the source code of your store category and product details pages.

See attached images.

Do you have any caching plugins installed? Make sure when you make changes you clear the cache before checking your changes.

bradleyhebdon April 10th, 2014 10:16 AM

AH, ok. I see it now. I was looking at the meta properties tags -- where it is not populating the title or the description correctly. Is this an SEO issue?

UPDATED - the product description isn't populating into the facebook share.

Eric April 10th, 2014 10:49 AM

Hi,

Here are the steps you need to get Facebook to work on your Product details page: http://www.datafeedr.com/forums/showthread.php?t=7168

Eric

bradleyhebdon April 10th, 2014 10:54 AM

Yup, I followed those - that's how I got facebook on the page.

Eric April 10th, 2014 11:37 AM

Hi,

You have your store set up fine but there must be another plugin you have installed adding that information to your head elements. In your source code I see this:

HTML Code:

<meta property="og:title" content="- Vintage Shopper"/>
That appears above your Datafeedr meta tags which are correct:

HTML Code:

<meta property="og:title" content="SAMPLE SALE - Maggie Sottero Spring 2013 - Alaina Ivory Satin &amp; Embellished Lace Wedding Dress"/>
Can you disable whatever plugin is also adding that information? At least disable it on the "Store" page.

Eric

bradleyhebdon April 10th, 2014 12:21 PM

The only plugin I could think of is the Yoast SEO, and I added the code you guys suggested to my functions.php file.

Eric April 10th, 2014 12:23 PM

Hi,

Which code was that?

Eric

bradleyhebdon April 10th, 2014 12:33 PM

function dfr_remove_wpseo_canonical( $canonical ) {
if (is_dfr()) {
$canonical = false;
}
return $canonical;
}
add_filter( 'wpseo_canonical', 'dfr_remove_wpseo_canonical' );

Eric April 10th, 2014 12:35 PM

Hi,

I think you also need this, too: http://www.datafeedr.com/forums/show...8024#post48024

Eric

Eric April 10th, 2014 12:41 PM

Hi,

Actually, I think you need this:

PHP Code:

add_filter'wpseo_opengraph_title''my_opengraph_title' );
function 
my_opengraph_title$title ) {
    if (
is_dfr()) { 
        
$title false;
    }
    return 
$title;
}

add_filter'wpseo_opengraph_desc''my_opengraph_desc' );
function 
my_opengraph_desc$desc ) {
    if (
is_dfr()) { 
        
$desc false;
    }
    return 
$desc;


Eric

bradleyhebdon April 10th, 2014 12:47 PM

Added, but it's still the same.

The product's description isn't populating into the facebook share.

Eric April 10th, 2014 01:04 PM

Hi,

I do see something is working. I posted 2 posts, above. Did you get my second one? That's what you need, not the first one.

Eric

bradleyhebdon April 10th, 2014 01:26 PM

Ok cool thanks mate. I think that fixed it.

one thing I have noticed though - on chrome, the facebook buttons don't show up for me. do they for you? On Firefox, they do.

http://www.vintageshopper.com/store/...dding-dresses/
http://www.vintageshopper.com/store/...7300195449550/

Eric April 10th, 2014 01:27 PM

Hi,

Yes, I'm on Chrome and they do appear.

Eric

bradleyhebdon April 10th, 2014 02:03 PM

OK, I think I'm having some caching issues. Thanks again for your help mate, greatly appreciated. It won't be the last you hear of me though ;)


All times are GMT -5. The time now is 01:10 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.