Datafeedr Support Forums

Datafeedr Support Forums (http://www.datafeedr.com/forums/index.php)
-   Problems (http://www.datafeedr.com/forums/forumdisplay.php?f=68)
-   -   Store won't display after update (Error 404) (http://www.datafeedr.com/forums/showthread.php?t=4387)

Eric April 25th, 2011 09:35 AM

Store won't display after update (Error 404)
 
If your store won't display (or you get a 404) after you have clicked the [Update Products and Settings] button, here are some steps to help troubleshoot the problem. After you perform each step below, be sure to check to see if your store is displaying properly.

1. Turn OFF any caching plugins.

This is essential and will save you hours of wasted time in the debugging process. Trust me. I've been there... ;)

2. Make sure there is only 1 WordPress Page for your store.



3. Make sure that your Store page slug matches the slug in your Advanced Store Settings.



4. Make sure your Store page is set to Public and is Published.



5. Make sure your Settings > Reading settings are configured correctly.

This section does not control whether your store appears on the front page of your site anymore. If you want your store to appear on the front page of your site, follow these directions.

If you have modified your Reading settings, you should reset those to these settings:


tblogster April 27th, 2011 07:17 AM

how do i know if i have any caching plugins?
and how do i turn them off?
(scuse my ignorance)
Naomi

Eric April 27th, 2011 07:58 AM

Quote:

Originally Posted by tblogster (Post 20222)
how do i know if i have any caching plugins?

You would have installed them. Go to your Plugins page and look for any plugin with the word 'cache' or 'caching' in the name and deactivate them until you are finished debugging.

AllenK919 May 4th, 2011 05:40 PM

Partial Update
 
When I update my store products and settings and configure my widgets, I only see the widgets on my website. Also, a store link is not automatically created. Should I set up a store page or is the program supposed to do that automatically?

Eric May 4th, 2011 06:52 PM

Quote:

Originally Posted by AllenK919 (Post 20398)
When I update my store products and settings and configure my widgets, I only see the widgets on my website. Also, a store link is not automatically created. Should I set up a store page or is the program supposed to do that automatically?

The Datafeedr plugin will create the necessary pages.

However, I went to your website and viewed your store successfully. It seems to me everything is set up properly.

Eric

kellihb May 20th, 2011 10:38 AM

I have had this store up for about 2 months and it was working fine. Today I got to check it and this is what is showing up on my home page:

<a href="/?q=store/product/buy/480000571016480/1-3-4-rhinestone-pasties" title="
Fatal error: Call to undefined function datafeedr_hh() in /home/content/02/6652102/html/sexyswimsuits/wp-content/plugins/datafeedr/datafeedr.php(1822) : eval()'d code on line 10

Inside of wp admin it states that my products are there but this is the code I am now getting. What happened?

Eric May 20th, 2011 10:39 AM

Hi

Please try following these steps: http://www.datafeedr.com/forums/show...0860#post20860

Eric

teeshirtdrama July 5th, 2011 08:35 AM

So if i go to pages and have no store pages in my page list do i need to create a new one?

Eric July 5th, 2011 08:40 AM

First, try to restore the "Store" page from your Trash. If the "Store" page is not in your Trash, then you will need to create a new one. But it's probably in your Trash.

blnklaus July 25th, 2011 05:49 PM

404 Error
 
I added some product to my store. after updating them my store was gone. There is only a 404 error:Not Found The requested URL /store/ was not found on this server.

i've checked all your tips in http://www.datafeedr.com/forums/show...1985#post21985 but thats all ok.

my Store iD is: 32205 my site is www.iappfel.de

blnklaus July 25th, 2011 06:02 PM

this effect is only on the store front page. If i go direct in a category page (for example: http://www.iappfel.de/store/category/imacs/ ) all is fine. I try do reset the store front page view in the factory but it don't help. The url setting means that all settings are ok:

Eric July 25th, 2011 06:45 PM

Quote:

Originally Posted by blnklaus (Post 22442)
I added some product to my store. after updating them my store was gone. There is only a 404 error:Not Found The requested URL /store/ was not found on this server.

i've checked all your tips in http://www.datafeedr.com/forums/show...1985#post21985 but thats all ok.

my Store iD is: 32205 my site is www.iappfel.de

What are your settings here: WordPress Admin Area > Settings > General?

blnklaus July 26th, 2011 12:31 AM

Quote:

Originally Posted by Eric (Post 22445)
What are your settings here: WordPress Admin Area > Settings > General?


Eric July 26th, 2011 07:37 AM

Hi

Can you PM me the following information:

BLOG LOGIN INFO with ADMINISTRATOR PERMISSIONS (Temporary login information preferred)
Admin URL:
Username:
Password:

FTP LOGIN INFORMATION (Temporary login information preferred)
Host:
Login:
Password:

Thanks,
Eric

Eric July 26th, 2011 08:46 AM

Quote:

Originally Posted by blnklaus (Post 22442)
I added some product to my store. after updating them my store was gone. There is only a 404 error:Not Found The requested URL /store/ was not found on this server.

i've checked all your tips in http://www.datafeedr.com/forums/show...1985#post21985 but thats all ok.

my Store iD is: 32205 my site is www.iappfel.de

The reason you were getting a 404 is because you had a directory named "store" in your root folder. I've renamed this to "store-data" and that fixed the problem. You can't have a page on your site and a directory on your server with the same name.

I also update your Datafeedr Directories settings to match this change.

Eric

blnklaus July 26th, 2011 08:55 AM

Quote:

Originally Posted by Eric (Post 22458)
The reason you were getting a 404 is because you had a directory named "store" in your root folder. I've renamed this to "store-data" and that fixed the problem. You can't have a page on your site and a directory on your server with the same name.

I also update your Datafeedr Directories settings to match this change.

Eric

Thank you very much, Eric. You're very patiently with such a stupid users like me.

mouthpiecemedia September 22nd, 2011 11:50 PM

This totally helped. The plugin didn't create any pages, but as soon as I manually created "Store," it was up and running. Thanks!

squeezywheezy October 20th, 2011 05:04 PM

Hi there, as of a few days ago my store does not work, it was working before! :) have tried all the tips above but nothing seems to be working - the title shop! still shows up on the shop homepage. anyhelp is much appreciated, thanks!
www.handbagfairy.co.uk/blog

Eric October 20th, 2011 06:02 PM

Hi

What are your settings on your Settings > Reading page?

Eric

squeezywheezy October 24th, 2011 05:35 PM

Hi Eric
the settings are "your latest posts" ticked
blog pages - 10 items
syndication 8 items
each article shows full text
encoding = utf8

Howeevr I notice that a new messaeg comes up when shop is clicked

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 40 bytes) in /home/handbagf/public_html/blog/wp-includes/taxonomy.php on line 158

Is this to do with it? How do I get it so that the images are not hosted locally? sorry for being completely stupid - im a little confused. many thanks
Louise

Eric October 24th, 2011 05:39 PM

Hi Louise

No, this is unrelated. You will have to send the error message to your host and ask them to increase your server's memory limits.

Eric

squeezywheezy October 26th, 2011 07:32 AM

many thanks eric

jackrock November 4th, 2011 06:35 PM

Please delete... Thanks.

Cutthroat February 16th, 2012 10:39 PM

Store ID: Cutthroat
Website URL: http://www.cutthroatcoupons.com
URL to page in question: http://www.cutthroatcoupons.com/store

Hi, I have read through this post and followed the steps. The "store" page shows up in menu navigation but when I click on it I still get the error 404 page. I can't figure out what I am doing wrong.
Cherrie @ CTC

Eric February 17th, 2012 10:06 AM

Hi

This is not a Datafeedr issue. Even when I go to http://www.cutthroatcoupons.com/about-us/ it's still a 404. Make sure you have configured your .htaccess file and Permalinks properly.

Eric

Cutthroat February 17th, 2012 10:26 AM

Store ID: Cutthroat
Yeah, I don't know what went wrong. Starting from the beginning. I'll be in touch if necessary :). Have a good one and thanks for the prompt response.

azjudy March 12th, 2012 10:16 AM

Changing "Auto-Update Options" to disable isn't working
 
I've double checked the list of recommendations to fix this issue and it's still happening. All my sites are hosted at Hostgator.

My problem occurs with the auto update. If there is a hiccup - all my stores get broken. I decided to disable the auto update 4 days ago through the datafeedr plugin settings. However, according to the update log, the store is still getting updated and broken when auto update occurs.

How can I turn auto update off?

Thanks!
-----------------------------------------------------------------------

Auto-Update Options

Auto-Update is currently: Disabled

Update Log

Last update started: 2012-03-12 15:00:16
Last update ended: 2012-03-12 15:00:28
Update stage:

Eric March 12th, 2012 10:18 AM

Hi

Welcome to the forums!

Quote:

Originally Posted by azjudy (Post 29749)
How can I turn auto update off?

You can also set the "Auto-update interval" to 0 here The Factory > Your Store > Store menu > Basic Store Settings.

Make sure to update your store's settings by clicking the [Update Settings Only] button after you make that change.

Eric

azjudy March 12th, 2012 10:27 AM

Thanks Eric - I hope that does the trick! :)

Eric March 12th, 2012 10:52 AM

Hi
Quote:

Originally Posted by azjudy (Post 29751)
Thanks Eric - I hope that does the trick! :)

If you have your debug log turned on, can you send that to us so we can see why the update ran?

Eric

azjudy March 14th, 2012 10:02 AM

Hi Eric,
I didn't see the last post about turning the "debug log" on until I was going to post this morning about another mystery update that broke the entire store again.

My last outclick on the store (per sitemeter stats) was 3/13 at 3:15pm PT - which told me the store pages were working. However, the update log said it last updated on 3/12 around 22:21:00 (which would be around 3:20 PT - but a day earlier???? ).

I was beginning to think that maybe something happened with the last product update that my son was working on, however, I went to my other datafeedr site (hosted at Hostgator), and saw that it broke too. It was working yesterday and then just broke around the same time.

The last update log says:
Update Log
Last update started: 2012-03-12 20:47:58
Last update ended: 2012-03-12 20:49:05
Update stage:

I now have "debug log" enabled

Eric March 14th, 2012 10:16 AM

Hi azjudy

Can you also perform these steps:

1. Upgrade your Datafeedr plugin to the newest version here: /WordPress Admin Area > Tools > Datafeedr > Plugin Upgrade

2. Then go here: WordPress Admin Area > Tools > Datafeedr > Updates > Packet Sizes and change both fields to 500 and save those changes.

3. Then click the [Update Products and Settings] button.

Eric

azjudy March 14th, 2012 10:17 AM

Another thought...

I don't think anyone was working on either broken site around the time they broke. However, I was working on setting up a third store around that time. That shouldn't have anything to do with the others breaking should it? When one store needs updating, do ALL of them get updated?

I hate mysteries...trying to find some logic with my frustration. :(

Eric March 14th, 2012 10:21 AM

Hi

In addition to the 3 steps I mentioned in my last post, can you also take this step: http://www.datafeedr.com/forums/show...7403#post27403

It might be that your /tmp directory is getting pruned mid-update and that can cause problems.

Eric

azjudy March 14th, 2012 11:42 AM

Hi Eric,
I did all 3 steps as you suggested. I also created a directory /storetmp and changed permissions to 777. In the other thread (http://www.datafeedr.com/forums/show...7403#post27403) it states to use an absolute url to the new directory - not a relative one.

Would that be http://www.mydomain.com/storetmp OR /home/username/public_html/storetmp ???

Eric March 14th, 2012 11:45 AM

Hi
Quote:

Originally Posted by azjudy (Post 29829)
Would that be http://www.mydomain.com/storetmp OR /home/username/public_html/storetmp ???

It would be: /home/username/public_html/storetmp

Eric

azjudy March 14th, 2012 11:58 AM

I tried that...and I get an error message saying "Directory not found" - It's in the exact same path as /tmp

Eric March 14th, 2012 12:01 PM

Hi

Did you already create the directory?

Did you change "username" to the proper value?

Eric

azjudy March 14th, 2012 12:09 PM

DOH!

I created the folder in the same area in file manager where the /tmp folder was. I just noticed that it wasn't in public_html, so I moved it and tried the new directory assignment again and it worked.

What is the code I need to add to the .htaccess file to "deny from all"? And would that go first or last in the .htaccess file?

Eric March 14th, 2012 12:30 PM

Hi

Glad you got it worked out.
Quote:

Originally Posted by azjudy (Post 29834)
What is the code I need to add to the .htaccess file to "deny from all"? And would that go first or last in the .htaccess file?

I think will answer your questions: http://stackoverflow.com/a/8683790

Eric


All times are GMT -5. The time now is 10:39 AM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.