Datafeedr Support Forums

Datafeedr Support Forums (http://www.datafeedr.com/forums/index.php)
-   Problems (http://www.datafeedr.com/forums/forumdisplay.php?f=68)
-   -   Error next to Details Button (http://www.datafeedr.com/forums/showthread.php?t=9503)

1800HART August 19th, 2013 04:26 PM

Error next to Details Button
 
I just noticed ... that on all my sites to the right of the "Details" button I get an error message.

When you click the "error" link, a popup comes up and kind of looks like a Facebook error message that says "The href URL is not properly formatted"


There error appears to be somewhere here after the "more details" code ... ?? but I can't seem to figure it out.

Code:

  <a href="[product.link]" title="[product.name]" class="dfbutton dforange dflarge dfrounded">more details</a>

<div class="fb-like" data-href="<?php echo urlencode('http://' . $_SERVER['HTTP_HOST'] . '/' . $product->site_link); ?>" data-send="true" data-layout="button_count" data-show-faces="true"></div>         
         
        </div>
      </div>
      <div class="clearingdiv"> </div>
   
     
    </div>
  </div>
  [product.end]
  <div class="clearingdiv"> </div>
</div>
<!-- /Product List -->


Q) Was this covered somewhere else in the forums?

Thanks!
HART

Eric August 19th, 2013 05:26 PM

Hi,

I think the issue is you have some Facebook code in there but you're missing the rest of it. The rest is here: http://www.datafeedr.com/forums/showthread.php?t=7168

Eric

1800HART August 19th, 2013 05:36 PM

Thanks ...

Although, I kind of figured that it is something with Facebook. The forum you showed me is putting Facebook on product detail listing pages which I already have it on and working. This error appears on the Category page view and do not understand where the code is coming that is either broken or messed up?

Eric August 19th, 2013 07:33 PM

Hi,

Then this is the code you'll need: http://www.datafeedr.com/forums/showthread.php?t=7169

Eric

1800HART August 19th, 2013 08:35 PM

I added that to this store .. http://software.hartmarket.com/store...ckup-software/ ... the LIKE/SEND to FB button appeared, but the "error" link next to each of the More Details button didn't disappear. Also when you click the LIKE button - it didn't go anywhere.

For the life of me - I don't recall putting on sharing buttons on the category view, just the individual product view - and, can't remember what used to be next to that More Details button? It's been a while for me.

Eric August 19th, 2013 09:55 PM

Hi,

You have Facebook code (correct and incorrect code) in every module of your Category Page view. That's what is causing the issue. If you want I can remove it from that view for you.

Eric

1800HART August 19th, 2013 11:07 PM

Quote:

Originally Posted by Eric (Post 44073)
Hi,

You have Facebook code (correct and incorrect code) in every module of your Category Page view. That's what is causing the issue. If you want I can remove it from that view for you.

Eric

That would be great Eric ... then, I will go and copy the code from the default Category Page view to all my other sites ... //

Take care.
HART

Eric August 20th, 2013 08:51 AM

Hi,

OK, I've removed all of the Facebook code from this view: http://factory3.datafeedr.com/feeder/view?view=162694

Eric


All times are GMT -5. The time now is 03:02 AM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.