Datafeedr Support Forums

Datafeedr Support Forums (http://www.datafeedr.com/forums/index.php)
-   Problems (http://www.datafeedr.com/forums/forumdisplay.php?f=68)
-   -   Store won't display after update (Error 404) (http://www.datafeedr.com/forums/showthread.php?t=4387)

Eric October 24th, 2011 05:39 PM

Hi Louise

No, this is unrelated. You will have to send the error message to your host and ask them to increase your server's memory limits.

Eric

squeezywheezy October 26th, 2011 07:32 AM

many thanks eric

jackrock November 4th, 2011 06:35 PM

Please delete... Thanks.

Cutthroat February 16th, 2012 10:39 PM

Store ID: Cutthroat
Website URL: http://www.cutthroatcoupons.com
URL to page in question: http://www.cutthroatcoupons.com/store

Hi, I have read through this post and followed the steps. The "store" page shows up in menu navigation but when I click on it I still get the error 404 page. I can't figure out what I am doing wrong.
Cherrie @ CTC

Eric February 17th, 2012 10:06 AM

Hi

This is not a Datafeedr issue. Even when I go to http://www.cutthroatcoupons.com/about-us/ it's still a 404. Make sure you have configured your .htaccess file and Permalinks properly.

Eric

Cutthroat February 17th, 2012 10:26 AM

Store ID: Cutthroat
Yeah, I don't know what went wrong. Starting from the beginning. I'll be in touch if necessary :). Have a good one and thanks for the prompt response.

azjudy March 12th, 2012 10:16 AM

Changing "Auto-Update Options" to disable isn't working
 
I've double checked the list of recommendations to fix this issue and it's still happening. All my sites are hosted at Hostgator.

My problem occurs with the auto update. If there is a hiccup - all my stores get broken. I decided to disable the auto update 4 days ago through the datafeedr plugin settings. However, according to the update log, the store is still getting updated and broken when auto update occurs.

How can I turn auto update off?

Thanks!
-----------------------------------------------------------------------

Auto-Update Options

Auto-Update is currently: Disabled

Update Log

Last update started: 2012-03-12 15:00:16
Last update ended: 2012-03-12 15:00:28
Update stage:

Eric March 12th, 2012 10:18 AM

Hi

Welcome to the forums!

Quote:

Originally Posted by azjudy (Post 29749)
How can I turn auto update off?

You can also set the "Auto-update interval" to 0 here The Factory > Your Store > Store menu > Basic Store Settings.

Make sure to update your store's settings by clicking the [Update Settings Only] button after you make that change.

Eric

azjudy March 12th, 2012 10:27 AM

Thanks Eric - I hope that does the trick! :)

Eric March 12th, 2012 10:52 AM

Hi
Quote:

Originally Posted by azjudy (Post 29751)
Thanks Eric - I hope that does the trick! :)

If you have your debug log turned on, can you send that to us so we can see why the update ran?

Eric

azjudy March 14th, 2012 10:02 AM

Hi Eric,
I didn't see the last post about turning the "debug log" on until I was going to post this morning about another mystery update that broke the entire store again.

My last outclick on the store (per sitemeter stats) was 3/13 at 3:15pm PT - which told me the store pages were working. However, the update log said it last updated on 3/12 around 22:21:00 (which would be around 3:20 PT - but a day earlier???? ).

I was beginning to think that maybe something happened with the last product update that my son was working on, however, I went to my other datafeedr site (hosted at Hostgator), and saw that it broke too. It was working yesterday and then just broke around the same time.

The last update log says:
Update Log
Last update started: 2012-03-12 20:47:58
Last update ended: 2012-03-12 20:49:05
Update stage:

I now have "debug log" enabled

Eric March 14th, 2012 10:16 AM

Hi azjudy

Can you also perform these steps:

1. Upgrade your Datafeedr plugin to the newest version here: /WordPress Admin Area > Tools > Datafeedr > Plugin Upgrade

2. Then go here: WordPress Admin Area > Tools > Datafeedr > Updates > Packet Sizes and change both fields to 500 and save those changes.

3. Then click the [Update Products and Settings] button.

Eric

azjudy March 14th, 2012 10:17 AM

Another thought...

I don't think anyone was working on either broken site around the time they broke. However, I was working on setting up a third store around that time. That shouldn't have anything to do with the others breaking should it? When one store needs updating, do ALL of them get updated?

I hate mysteries...trying to find some logic with my frustration. :(

Eric March 14th, 2012 10:21 AM

Hi

In addition to the 3 steps I mentioned in my last post, can you also take this step: http://www.datafeedr.com/forums/show...7403#post27403

It might be that your /tmp directory is getting pruned mid-update and that can cause problems.

Eric

azjudy March 14th, 2012 11:42 AM

Hi Eric,
I did all 3 steps as you suggested. I also created a directory /storetmp and changed permissions to 777. In the other thread (http://www.datafeedr.com/forums/show...7403#post27403) it states to use an absolute url to the new directory - not a relative one.

Would that be http://www.mydomain.com/storetmp OR /home/username/public_html/storetmp ???

Eric March 14th, 2012 11:45 AM

Hi
Quote:

Originally Posted by azjudy (Post 29829)
Would that be http://www.mydomain.com/storetmp OR /home/username/public_html/storetmp ???

It would be: /home/username/public_html/storetmp

Eric

azjudy March 14th, 2012 11:58 AM

I tried that...and I get an error message saying "Directory not found" - It's in the exact same path as /tmp

Eric March 14th, 2012 12:01 PM

Hi

Did you already create the directory?

Did you change "username" to the proper value?

Eric

azjudy March 14th, 2012 12:09 PM

DOH!

I created the folder in the same area in file manager where the /tmp folder was. I just noticed that it wasn't in public_html, so I moved it and tried the new directory assignment again and it worked.

What is the code I need to add to the .htaccess file to "deny from all"? And would that go first or last in the .htaccess file?

Eric March 14th, 2012 12:30 PM

Hi

Glad you got it worked out.
Quote:

Originally Posted by azjudy (Post 29834)
What is the code I need to add to the .htaccess file to "deny from all"? And would that go first or last in the .htaccess file?

I think will answer your questions: http://stackoverflow.com/a/8683790

Eric


All times are GMT -5. The time now is 01:51 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.